Thoughtful, detailed coverage of the Mac, iPhone, and iPad, plus the best-selling Take Control ebooks.

 

 

Pick an apple! 
 
Move the Dock Quickly

You may find it convenient to move the position of the Dock when working in certain programs or with certain files. Rather than choosing a different position from the Dock preferences pane or using a submenu in the Apple menu's Dock submenu, you can move your Dock to a different screen edge merely by Shift-dragging the separator that divides the application and document sections.

Visit plucky tree

Submitted by
cricket

 
 

Lion and Mountain Lion Still Available, Unlike iOS 6

Send Article to a Friend

There are times that Apple, which is famous for presenting a single unified face to the world, seems to suffer from a multiple personality disorder. Case in point — if you have an older Mac and want to upgrade to OS X 10.7 Lion or 10.8 Mountain Lion, even after the release of 10.9 Mavericks (see “Apple Releases OS X 10.9 Mavericks for Free,” 22 October 2013), Apple will sell you a $19.99 redemption code via the Apple Online Store, which you then redeem in the Mac App Store. This roundabout approach is necessary because Apple keeps only the latest version of Mac OS X — now Mavericks — visible in the Mac App Store, presumably to prevent customer confusion.


(And yes, that means you must be upgrading a Mac running 10.6.8 Snow Leopard or be willing to jump through some hoops to make an installer disk. Both “Take Control of Upgrading to Lion” and “Take Control of Upgrading to Mountain Lion” remain available for those who need reminders on what to do.)

Once you have the redemption code, open the App Store app, and in the Quick Links section of the Featured view, click Redeem and enter your code.


This is all very reasonable, even though Mavericks runs on all the same Macs that Mountain Lion supports. There are any number of other reasons why someone may wish to upgrade an older Mac from Snow Leopard to Lion or Mountain Lion instead of Mavericks, mostly having to do with software compatibility (or problems with Apple Mail and Gmail — for details, see “Mail in Mavericks Changes the Gmail Equation,” 22 October 2013), and it’s nice to see that Apple is making it possible for the vanishingly small number of people who wish to buy one of these older operating systems to do so.

So why is it that Apple won’t even allow iOS device owners who have upgraded to iOS 7 to downgrade to iOS 6? For a non-trivial number of users, iOS 7’s new look is unreadable, despite the accessibility options Apple added in an attempt to address the concerns (see the comments on “Peering at iOS 7 for the Vision Impaired,” 19 September 2013). The overall design of iOS 7 isn’t a bug to be fixed or an option to be set. iOS 7.0.3 may have addressed the problem of the parallax effect and animations causing motion sickness by souping up the Reduce Motion switch (see “iOS 7.0.3 Adds iCloud Keychain and Disables Animation,” 22 October 2013), but even the Larger Dynamic Text and Bold Text options aren’t sufficient for many users.

These people aren’t asking for changes to iOS 7, they’re just asking to be allowed to downgrade to iOS 6, and yet the same company that helpfully still sells the last two versions of Mac OS X won’t let them. What could possibly be the reason?

Check out the Take Control ebooks that expand on the topic in this article:

Upgrade to Lion successfully with Joe Kissell's advice, gained through countless test installs. Learn what to do if you can't download from the App Store, avoid problems, and perform key post-upgrade tasks. Covers upgrading from Tiger or Leopard, Lion Server installation basics, migrating to a new Mac, and Recovery mode.
Make the move to Mountain Lion with Joe Kissell’s expert advice! Sort out compatibility issues, deal with Apple IDs, make a suitable backup, and pick your upgrade plan — including a clean install. You’ll also learn about key post-upgrade tasks, what to do if something goes terribly wrong, and how to “upgrade” to Mountain Lion while moving from an older Mac or Windows PC.

 

READERS LIKE YOU! Support TidBITS by becoming a member today!
Check out the perks at <http://tidbits.com/member_benefits.html>
Special thanks to Edward O'Neal, Mark Alexander, Juerg Fehr, and
Julian Patrick for their generous support!
 

Comments about Lion and Mountain Lion Still Available, Unlike iOS 6

Frans Moquette  2013-10-25 09:58
What could possibly be the reason?

I've been asking that question a lot the past few years.

Why did Apple drop Rosetta support in Lion?

Why did Apple not add support for iCloud in Snow Leopard?

Why does Apple not allow you to run an older OS in a virtual machine?

Why doesn't Apple make it easy to 'step back' in iOS when you dislike the updated version of an app?

And, yes, why won't Apple let you 'step back' to a previous version of iOS when the new version misbehaves or you simply don't like it?

Doesn't Apple like its long time users?

I really think Apple should implement something like Time Machine for iOS. Seamlessly and transparently via iCloud. So, when an update does not perform as you expect, or you just don't like it, you can simply 'step back'.
Adam Engst  An apple icon for a TidBITS Staffer 2013-10-25 10:55
I do think it's important to distinguish between technical issues and those that are based simply on policy. For instance, maintaining Rosetta, adding iCloud support in Snow Leopard, and so on are technical issues with ongoing technical costs.

But things like virtual machine restrictions and refusing to allow iOS downgrades have no technical reasoning behind them.

In fact, restoring backups in iOS is exactly like Time Machine in the sense of bringing back your settings at that point in time... except for the version of iOS.
Frans Moquette  2013-10-25 12:08
Agree on the technical vs policy distinction. Although it does make me wonder where to put Apple's refusal to support iCloud in Snow Leopard, since they did support it on Windows XP!
I'm curious about your comment on restoring in iOS being exactly like Time Machine. How do you restore a single app on iOS, with all it's data intact?
Adam Engst  An apple icon for a TidBITS Staffer 2013-10-25 12:10
Yeah, you can't restore a single app, but it's really easy to bring an iOS device back from a backup.

My iPhone's upgrade to iOS 7.0.3 borked, and I had to restore entirely. While it took a while to resync all the apps and media, it was painless otherwise.
artMonster  2013-10-25 13:46
I have no idea why the restrictions on VM. I think perhaps Apple prefers to not allow iOS downgrades for a couple reasons. They know their roadmap and maybe for security reasons as well as legacy support they want to try to get as many users as possible to stay current. Even if it means the loss of those customer's to the competition.
Frans Moquette  2013-10-25 15:03
Completely restoring an iOS device just to bring back a previous version of one single app is a big hassle I think. And you will lose data if you're not careful and follow specific steps. For a non-power user this is an almost impossible task.

Apple is about ease of use for all users. Apple should make it easy to 'step back' when you want to restore just a single app. The implementation could be that the user puts an app in 'wiggly mode', taps the x and then is presented with the choices delete and step back. The last choice restores the previous version with all its data from iCloud. The data was automatically backed up just before installing the update.

A feature like that would make me a lot less hesitant to upgrade. I think I am not alone.
Christopher Shay  2013-10-25 14:07
iOS upgrades can include firmware updates, which could result in the "bricking" of your device if there is an incompatibility. So there is a technical aspect to the decision. Also a security minded one, as an iOS update could resolve a major flaw. Allowing the user to roll back could open them up for an exploit. Most of the articles that I find that explore rolling back the OS are for jailbreaking the device, not to resolve some issue.

All of these "annoying" choices are made for the greater good of the overall user experience, not at random, not as part of some Apple conspiracy to drive new purchases.
gastropod  2013-10-26 15:06
I avoid restores like the plague. 10-15 gigabytes of data does not get backed up (things that are marked 'oh, this was downloaded, they can just download it again). Since I'm on slow dsl, this is not a trivial issue, even not counting the time it takes to remember what it is I need to download and set the parameters to do it (such as map boundaries/detail). Some apps let you force downloaded content to backup, but not all.
Adam Engst  An apple icon for a TidBITS Staffer 2013-10-25 14:33
I'd be curious if such firmware updates are removed if you use DFU mode to reset first. That's my impression from reading about them. Nevertheless, if downgrading would brick the device, that's a different story. And if it were the case, Apple should be alerting users to that before performing the update - it's unfriendly at best to send customers down a one-way street without warning.

But I'm not buying the security issue at all - since Apple isn't forcing everyone to upgrade, anyone who chooses to remain on iOS 6 would be vulnerable to any exploits Apple doesn't fix. So there's no significant security difference for someone who chooses to downgrade as for someone who chooses not to upgrade. Perhaps it is related to an effort to reduce jailbreaking, but while I'm personally uninterested in (and don't recommend) jailbreaking, I don't believe such people are doing anything wrong, and people who inadvertently upgrade to iOS 7 and dislike it shouldn't be lumped in with jailbreakers.

And I'm not suggesting that Apple is doing this to drive new purchases at all - that would at least be rational, if user-hostile. Since iOS 7 is a free update, and making it a one-way street is only going to result in driving some percentage of users away from the platform, or at least significantly reducing their usage and satisfaction with it, the only result to Apple's bottom line would be negative. That's why the decision to prevent downgrades seems capricious.
Minus van Baalen  2013-10-28 11:59
"Borked"?
Frans Moquette  2013-10-25 15:21
Where security is concerned, I think Apple should support older OS versions with security updates for several years (at least 5 would be reasonable I think). Some older hardware won't support iOS 7. For some devices iOS 5 or maybe 4 is the latest supported.

When you buy an iOS device you buy it with the features it has. You implicitly expect it to be secure. If it isn't, that is a flaw Apple should fix. You can't complain because your device doesn't support some new feature you know it didn't have in the first place, but you can complain when your device is not secure.
xandra  2013-11-19 19:38
Adam,
Unless they've changed it in iOS 7 You CAN restore a single app (if you still have a copy of the old version*.

Delete the new version from your device(s), then delete it from your computer (or hide/compress the new version) while iTunes isn't running.
Next drag the old version to the mobile apps folder, and double click it. iTunes launches, recognizes the new one. It's possible you'll have to sync via iTunes while device is connected for it to reinstall.

*This is one reason I prefer to update and sync via iTunes. Older versions are left in the trash whenever you update apps. (I keep these rather than having to search through Time machine)
Adam Engst  An apple icon for a TidBITS Staffer 2013-11-20 07:22
Good technique, thanks!
Michael Schmitt  2013-10-26 13:38
There doesn't seem to be any direct path to navigate to Lion or Mountain Lion products in the Apple Store. (For example, Shop Mac > Accessories > Software only leads to Quicktime from Apple)

The only way I could find it is by searching for "OS X Lion" or "OS X Mountain Lion" in the store.
gastropod  2013-10-26 15:00
And if you want Snow Leopard Server, you have to use the phone; it's nowhere on the website. But it's worth doing--you can get it for $20 (if they still have any), which lets you run snowie virually without a hassle on old enough hardware. It's easy to ignore the server parts, IIRC no services are turned on by default. Note that you need multiple licenses to run multiple copies at the same time.
Adam Engst  An apple icon for a TidBITS Staffer 2013-10-26 15:29
I can almost understand this, in that Apple wants to make sure people buying these older versions really need them, and aren't just confused. But seems a little silly, even still.
gastropod  2013-10-26 14:56
It's worse than not letting you change your mind after upgrading. I was forced to upgrade against my will. My iphone was having severe problems, so I had to do a restore. I was on iTunes 10.7 because I despise 11, and I didn't want ios 7 anyway; 6 has been perfect. Restore had me spend three hours downloading 6.03, then wouldn't let me install it. I had to install itunes 11, then spend another 4 hours downloading the unwanted ios 7. Some of my apps were unrestorable, partly due to in-app purchases. I'm out at least $30 for orphan software that worked great on ios 6 but can't be restored on 7. Fortunately I have some old macs that can run old iTunes, once I make the music available on a shared disk (more wasted time).

Not a happy camper. I wish so much that apple had any decent competition.
Ken Powell  2013-10-29 07:02
Older versions of iOS are available using links on the OSXdaily site. OSXdaily has instructions on how to use IPSW (I Phone/Pad Soft Ware) files here:

http://osxdaily.com/2010/11/23/how-to-use-ipsw-files/

Links to download the files are in the last section entitled "Where do you get IPSW files?". I haven't tried doing an iOS downgrade on any device, so I don't know whether this will help...
Adam Engst  An apple icon for a TidBITS Staffer 2013-10-29 07:56
My understanding is that Apple rescinded the digital signature necessary for older versions of iOS to install, so it simply won't work.
Ken Powell  2013-10-29 15:33
That explains the behavior seen by gastropod. In other words, it's not possible to reload an older version of iOS using Apple's tools. No warning you're headed down a one-way street by doing an 'upgrade'. I'm disappointed but not surprised; how sadly typical of Apple.
Norbert E Fuchs  An apple icon for a TidBITS Benefactor 2013-10-29 06:44
"... if you have an older Mac and want to upgrade to OS X 10.7 Lion or 10.8 Mountain Lion, even after the release of 10.9 Mavericks (see “Apple Releases OS X 10.9 Mavericks for Free,” 22 October 2013), Apple will sell you a $19.99 redemption code via the Apple Online Store, which you then redeem in the Mac App Store..."

Does this also mean that after having installed Mavericks I can go back to Mountain Lion?

I'd like to because I absolutely refuse to use iCloud to synchronise Calendar and Contacts, and want the local sync (Wifi or USB) back. Also 1Password seems to have some problems with Mavericks.
Adam Engst  An apple icon for a TidBITS Staffer 2013-10-29 09:05
You can certainly downgrade to Mountain Lion if you want (there are instructions in Joe's "Take Control of Upgrading to Mavericks") but you don't need to repurchase Mountain Lion to do it.
david cuddy  An apple icon for a TidBITS Supporter 2013-10-30 16:24
Apple's anti-consumer upgrade policies are really p***ing me off, obstructing my work, and wasting my time.

Three weeks ago I bought Pages V4.3 on the App Store ($19.95 plus tx). At the time, Pages was advertised as being compatible with Mountain Lion, Snow Leopard, etc. Earlier this week, I attempted to download/install it on my MacBook Air (running 10.6.8). The App Store refused to download it, citing Mavericks as a prerequisite. The App Store now has Pages V5 (all-new, all-improved...). Pages V4 has vanished.

As much as I'd like to put Mavericks on my MBA, I can't. It's a 1st-gen model and is capped at 10.6. It's a bit old, but is quite serviceable, especially since I replaced the horribly-slow hard drive with an SSD. It's fully capable of running Pages V4 (ie. iWorks '09), but Apple's policies on s/w distribution prevent me from doing so. The money I paid to buy Pages on the App Store was totally wasted. (another reason NOT to use the App Store for software purchases).

I contacted Apple's 'Customer Service', whose response was that I must "upgrade to the latest OSX Mavericks". It was apparent that the CSR (Karan) did not bother to read the trouble ticket, as I had explained clearly that I was not able to upgrade to Mavericks.

It appears that Apple has not thought through the implications of their singular focus on mandating upgrades to the latest & greatest. They are abandoning 'older hardware' (where in some cases, can be a device purchased only a few months ago), and in doing so jeopardizing customer loyalty.
Nicholas Barnard  2013-10-30 16:58
Oftentimes upgrades to the OS are required to upgrade an application because the OS adds an one or a few thousand new APIs. I'd bet that iWorks 5 requires some of those APIs.

I'd really love my Apple II to run OS X, but I know that ain't going to happen. As Steve Jobs put it when someone complained that their Apple TV wasn't being upgraded: It does everything it did when you bought it.

If anything Apple has tried to keep the hardware requirements to a minimum. I have a 4+ year old machine that runs mavericks swimmingly (well, with a new SSD..)
Bill Womack  2013-11-09 22:30
I'd love to revert back to iOS 6.x on my iPhone 4S. iOS7 has left me (and many others) without working WiFi and a very sluggish phone that worked perfectly before.

I can restore WiFi only by putting the phone... literally... in the freezer until it cools enough to work properly. As soon as it reaches "normal" room temperature, WiFi is lost again.

N—furiating.
Bhaskar Bhat  2013-11-17 06:03
I have no clue why people who claim themselves to be Apple loyalists would like to think that, they should rule the company's decisions. If you do not like iOS 7 best way to do is to switch. Apple cannot allow iOS 6 downgrade and still propagate developers to update/build apps for iOS 7. So called fanboys should buy Samsung Galaxy which have no time bound upgrade or terrible battery and performance.