Thoughtful, detailed coverage of the Mac, iPhone, and iPad, plus the best-selling Take Control ebooks.

 

 

Pick an apple! 
 
View Extra Bluetooth Details in Snow Leopard

In Snow Leopard, Option-click the Bluetooth icon in the menu bar to view a few additional items in the Bluetooth menu. Specifically, it enables you to open three utility applications: Bluetooth Explorer, Bluetooth Diagnostic Utility, and PacketLogger. These are likely of interest primarily to experts, but if you're having troubles with Bluetooth, the Bluetooth Diagnostic Utility in particular may be useful. (These tools are available only if you've installed Apple's Developer Tools.)

Submitted by
Doug McLean

 

 

Published in TidBITS 61.
Subscribe to our weekly email edition.

 

 

System Version News

Send Article to a Friend

System system, who's got the system? Apple has a couple of them that you might be interested in, so pay attention. You thought that System 7 was going to be the only System Software released in the next few months, but you weren't counting on 6.0.8. It's not exactly interesting, since 6.0.8 has no added features and no bug fixes (not that there were any bugs in 6.0.7 - read on for more about that), but it does contain System 7-compatible printing software. You'll want that software because otherwise you'll be reinitializing laser printers right and left every time a Mac with different System Software prints. As of July 1st, 6.0.8 will also ship with all Macs that can't run System 7 because they don't have enough memory (the Mac Classic, floppy-drive LC, and a few other options). So those of you that don't have enough memory for System 7 can rest easy - Apple hasn't forgotten about you yet (and I emphasize the 'yet'). Apple wants everyone to upgrade to System 7, but if you can't, 6.0.8 replaces 6.0.7 as the version of choice, particularly for networks that want to standardize. However, if you don't share a printer and can't upgrade to 7, there's no reason to change what works for you now.

Apple has released a statement concerning "bugs," to use Apple's quotes, in 6.0.7. A number of people have complained about various problems in 6.0.7 that may not indeed be Apple's fault. The three main problems that seemingly implicate 6.0.7 are faulty 2 MB SIMMs from some third party manufacturers, that confusing "Co-processor not installed" message, and an incompatibility with the WDEF virus.

You can check problems possibly caused by bad 2 MB SIMMs by removing them and running without extra memory for a bit. Then contact the manufacturer for more information. The "Co-processor not installed" messages are usually due to errors in programs that would previously have bombed with a "System Error ID = 10" message - with the new message Apple attempts to be more informative, even though in this case it's not all that helpful. Finally, if you have the WDEF virus and use 6.0.7, you'll run into serious system crashes until you remove the infection. Apple recommends running Disinfectant 2.4 on all your disks in order to ferret out WDEF, which otherwise spreads like wildfire.

System 7's biggest bugaboo will be compatibility, and Apple is trying to ease the transition by including a Compatibility Checker with the release. Here are some other notes that Apple has released recently which might be of assistance in the process. Hardware-wise, System 7 works with all Macs with from the Plus up (the 128, 512, and 512KE need the Plus Logic Board Kit and the Disk Drive Kit) if and only if (I guess that's spelled iff in math terms) they have 2 MB of RAM and a hard disk. Of course, virtual memory only works on 68030 Macs and the Mac II with a 68851 PMMU. Networks should have no trouble iff you upgrade the printer drivers on the System 6 Macs.

As far as software goes, it's a bit more complex. Use the Compatibility Checker before you install System 7. A number of Apple products require upgraded software to work with System 7, so if you have any Apple SCSI hard drive (who knows about the old serial drives), the 5.25" drive, Apple EtherTalk or TokenTalk cards, any Apple printer, or the Portable Backlight Screen Upgrade, you should install the new software from the System 7 disks. If you have the AppleCD SC CD-ROM drive, the Apple Scanner, or Inter*Poll, see your dealer for new software that will work with System 7. You'll have to wait a while for upgrades to MacTCP, MacX 1.1, MacDFT, the Apple Coax/Twinax Card w/MacDFT (whatever that is :-)), A/UX 2.0.1, and Macintosh Display Card 8*24 GC (the software doesn't work in accelerated mode). If you've got an Apple Tape Backup 40SC, throw it out... oops, sorry, I meant to say that it won't work with System 7, but it should work with third-party backup software. Apple also says that you shouldn't upgrade A/UX configurations or server bundles to System 7, and that you shouldn't install AppleShare Print Server or AppleShare File Server 2.0 on a System 7 Mac. They work fine on a System 6 Mac and will talk to System 7 Macs with no trouble. Gee, do you think this means that AppleShare 3.0 can be too far away?

Information from:
Apple Worldwide Product Marketing Information
Mark H. Anbinder -- mha@memory.uucp
Patrick Kuras -- KURAS@applelink.apple.com

 

READERS LIKE YOU! Support TidBITS by becoming a member today!
Check out the perks at <http://tidbits.com/member_benefits.html>
Special thanks to Joseph Fanelli, Fredrik Borch Lynghaug, Murray, and
John Craig for their generous support!