Skip to content
Thoughtful, detailed coverage of everything Apple for 28 years
and the TidBITS Content Network for Apple professionals
20 comments

Apple Support for Snow Leopard Wanes

When is it time to make the jump to a new version of Mac OS X? You can upgrade any time, assuming your hardware and essential software are compatible. But what if you see no benefit in upgrading? How long can you wait?

Throughout Apple’s entire history, the one activity that always forces an operating system upgrade is buying a new Mac. Macs have always come with the latest version of the operating system, and seldom has it been possible to downgrade in any real way. This is both sensible and intentional — Apple can better take advantage of new hardware capabilities if it doesn’t also have to maintain backward compatibility, and just testing new software on old hardware has significant costs.

But no longer can you sit forever on a perfectly functional combination of a Mac and Mac OS X, at least not if you use the Internet. While it has created great good in our lives, connecting to the Internet also makes us vulnerable to digital exploitation, and the security fixes that Apple provides for Mac OS X and key apps like Safari and Mail are necessary for reducing that vulnerability. The longer you use an unpatched version of Mac OS X, the higher the risk that you could suffer data loss, financial attack, or even identity theft.

For many years, Apple maintained an “n-1” policy with regard to security fixes, updating the current version of Mac OS X and issuing a security update for the previous one. So, when Apple released Mac OS X 10.6.7 for Snow Leopard, the company also rolled out Security Update 2011-001 for 10.5 Leopard. Starting with 10.8 Mountain Lion, Apple extended that to “n-2” to protect both 10.7 Lion and 10.6 Snow Leopard, most recently releasing Security Update 2013-004 for both operating systems in September 2013.

Apple never explained the change, but it may have had to do with supporting older Intel-based Macs that customers held onto in order to run PowerPC-compatible apps via Rosetta. Rosetta went away with the release of Lion, forcing many customers to delay upgrades until new versions of key apps were released (see “Preparing for Lion: Find Your PowerPC Applications,” 6 May 2011).

We’re now at 10.9 Mavericks, and while Apple has maintained the “n-2” policy surrounding security updates, that means support for 10.8 Mountain Lion and 10.7 Lion, with 10.6 Snow Leopard apparently pushed off the back of the truck. The recent Security Update 2014-001 isn’t available for Snow Leopard, and while Apple also released Safari 6.1.2 for Mountain Lion and Lion, Snow Leopard can run only Safari 5. (Luckily, Google Chrome and Firefox both remain compatible with Snow Leopard and continue to receive updates; both are safer choices for the Snow Leopard user.)

As always, Apple has said nothing official about Snow Leopard support; it’s entirely possible that the company could release another security update for it if the vulnerability in question were sufficiently widespread and damaging.

So does all this mean you must upgrade from Snow Leopard immediately? Not necessarily. The security vulnerabilities fixed in Security Update 2014-001 may not even affect Snow Leopard. In a careful reading of the security update’s release notes, none of the vulnerabilities struck me as particularly worrying for the Snow Leopard user. In particular, the major SSL/TLS vulnerability that affected Mavericks, iOS, and Apple TV doesn’t appear to be a problem for Snow Leopard (see “10.9.2 Fixes Critical SSL Security Bug, Adds FaceTime Audio,” 25 February 2014). Realistically, if you don’t run Apache or PHP under Snow Leopard, and you maintain safe browsing habits (stick to mainstream sites, don’t download unknown content, and be generally cautious), I think the likelihood of trouble is low.

Part of the reason for that is that most Mac users are running Mavericks now, so those running older versions of Mac OS X aren’t as compelling targets for online criminals. How many people are still running Snow Leopard? According to NetApplications, it could be nearly 1 in 5 Mac users, although other stats, such as those from The Omni Group, put it at more like 1 in 12. More broadly, even the NetApplications stats put Snow Leopard at only 1.4 percent of the overall Internet user base.

So, if you’re still running Snow Leopard, what should you do? The first option is nothing. It’s a risk, but probably not a huge one, and sometimes we choose convenience over safety — do you perform a basic safety check on your car before every trip? Didn’t think so.

To reduce that risk, you can upgrade to Mavericks for free via the Mac App Store, assuming your hardware supports it. Here’s a list of supported models; to find out what you have, choose About This Mac from the Apple menu, and then click the More Info button. For full instructions, read Joe Kissell’s “Take Control of Upgrading to Mavericks.”

  • iMac (Mid 2007 or newer); aka iMac7,1 or newer
  • MacBook (13-inch Aluminum, Late 2008; or 13-inch Early 2009 or newer); aka MacBook5,1 or newer
  • MacBook Air (Late 2008 or newer); aka MacBookAir2,1 or newer
  • MacBook Pro (13-inch, Mid-2009 or newer; 15-inch, Mid/Late 2007 or newer; or 17-inch, Late 2007 or newer); aka MacBookPro3,1 or newer
  • Mac mini (Early 2009 or newer); aka Macmini3,1 or newer
  • Mac Pro (Early 2008 or newer); aka MacPro3,1 or newer
  • Xserve (Early 2009); aka Xserve3,1 or newer

Given the fixes in 10.9.2, going all the way to Mavericks makes the most sense to me, but it’s also possible to upgrade just to Mountain Lion if you have concerns about Mavericks. The two share the same hardware requirements, so if your Mac is on the list above, it can also run Mountain Lion. It costs $19.99 from the Apple Store, and Apple will send you a Mac App Store redemption code via email. Again, check out “Take Control of Upgrading to Mountain Lion” for details.

Some older Macs can run Lion, but not Mountain Lion. In my opinion, hardware limitations are the only reason to run Lion; Mountain Lion and Mavericks are both better otherwise. Lion requires at least an Intel Core 2 Duo processor. Not sure what processor your Mac has? Choose About This Mac from the Apple menu and look at what the Processor line says. Look for Intel Core 2 Duo, Core i3, Core i5, Core i7, or Xeon. Anything else — specifically, “Core Duo” (without the 2) or “Core Solo” — and you won’t be able to run even Lion. Should you be able to and wish to upgrade to Lion, though, you can purchase a $19.99 redemption code for the Mac App Store, and “Take Control of Upgrading to Lion” has instructions.

Finally, budget permitting, you can simply buy a new Mac, which will come with Mavericks pre-installed. And although I know you’re pretty happy with your older Mac running Snow Leopard, I can guarantee that Macs have come a long way in the intervening 3–5 years, with notably improved performance, screens, and battery life. I’ve never felt that a new Mac was a step backwards from the one it replaced, and I doubt you will either.

Subscribe today so you don’t miss any TidBITS articles!

Every week you’ll get tech tips, in-depth reviews, and insightful news analysis for discerning Apple users. For 28 years, we’ve published professional, member-supported tech journalism that makes you smarter.

Registration confirmation will be emailed to you.

Comments About Apple Support for Snow Leopard Wanes