<!DOCTYPE html>
<html class="no-js" lang="en" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<title>What APFS Does for You, and What You Can Do with APFS - TidBITS</title>
<link rel="stylesheet" property="stylesheet" href="https://tidbits.com/app/themes/tidbits/styles/main.css?id=1d0980858c90e6a65227">
<link rel="stylesheet" property="stylesheet" href="https://tidbits.com/app/themes/tidbits/styles/print.css?id=8d1e1596a110004fcdf3" media="print">
<meta name="viewport" content="width=device-width, initial-scale=1">
<script>document.documentElement.className = document.documentElement.className.replace('no-js', 'js');</script>
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#80298e">
<meta name="apple-mobile-web-app-title" content="TidBITS">
<meta name="application-name" content="TidBITS">
<meta name="msapplication-TileColor" content="#80298e">
<meta name="theme-color" content="#80298e">
<title>What APFS Does for You, and What You Can Do with APFS - TidBITS</title>

<link rel="canonical" href="https://tidbits.com/2018/07/23/what-apfs-does-for-you-and-what-you-can-do-with-apfs/" />
<link rel="publisher" href="https://plus.google.com/108618773615035491147" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="What APFS Does for You, and What You Can Do with APFS - TidBITS" />
<meta property="og:description" content="macOS High Sierra switched to APFS (Apple File System) for Macs with solid-state storage, but what does it do? Jeff Carlson explains why Apple made the change, how APFS works, and what it can do for you." />
<meta property="og:url" content="https://tidbits.com/2018/07/23/what-apfs-does-for-you-and-what-you-can-do-with-apfs/" />
<meta property="og:site_name" content="TidBITS" />
<meta property="article:publisher" content="http://www.facebook.com/pages/TidBITS/195314925519" />
<meta property="article:tag" content="APFS" />
<meta property="article:tag" content="Fusion Drive" />
<meta property="article:tag" content="hard disk" />
<meta property="article:tag" content="SSD" />
<meta property="article:tag" content="storage" />
<meta property="article:section" content="Mac &amp; macOS" />
<meta property="article:published_time" content="2018-07-23T13:55:06-04:00" />
<meta property="article:modified_time" content="2018-07-25T14:06:08-04:00" />
<meta property="og:updated_time" content="2018-07-25T14:06:08-04:00" />
<meta property="og:image" content="https://tidbits.com/wp/../uploads/2018/07/Hard-drive-and-an-SSD.jpg" />
<meta property="og:image:secure_url" content="https://tidbits.com/wp/../uploads/2018/07/Hard-drive-and-an-SSD.jpg" />
<meta property="og:image:width" content="1999" />
<meta property="og:image:height" content="1079" />
<meta property="og:image:alt" content="A laptop hard drive next to an SSD." />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="macOS High Sierra switched to APFS (Apple File System) for Macs with solid-state storage, but what does it do? Jeff Carlson explains why Apple made the change, how APFS works, and what it can do for you." />
<meta name="twitter:title" content="What APFS Does for You, and What You Can Do with APFS - TidBITS" />
<meta name="twitter:site" content="@TidBITS" />
<meta name="twitter:image" content="https://tidbits.com/wp/../uploads/2018/07/Hard-drive-and-an-SSD.jpg" />
<meta name="twitter:creator" content="@jeffcarlson" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/tidbits.com\/","sameAs":["http:\/\/www.facebook.com\/pages\/TidBITS\/195314925519","https:\/\/plus.google.com\/108618773615035491147","https:\/\/www.youtube.com\/channel\/UC6FJi0g8Dc8Ou3D1YmW8nCA","https:\/\/twitter.com\/TidBITS"],"@id":"https:\/\/tidbits.com\/#organization","name":"TidBITS Publishing Inc.","logo":"https:\/\/tidbits.com\/wp\/..\/uploads\/2018\/02\/TidBITS_Logo_Final.png"}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="TidBITS &raquo; Feed" href="https://tidbits.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="TidBITS &raquo; Comments Feed" href="https://tidbits.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="TidBITS Podcast" href="https://tidbits.com/feed/podcast/" />
<link rel="alternate" type="application/rss+xml" title="TidBITS &raquo; What APFS Does for You, and What You Can Do with APFS Comments Feed" href="https://tidbits.com/2018/07/23/what-apfs-does-for-you-and-what-you-can-do-with-apfs/feed/" />
<link rel='stylesheet' id='jetpack_related-posts-css' href='https://tidbits.com/app/plugins/jetpack/modules/related-posts/related-posts.css' type='text/css' media='all' />
<script type='text/javascript' src='https://tidbits.com/wp/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://tidbits.com/wp/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tidbits.com/app/plugins/jetpack/_inc/build/related-posts/related-posts.min.js'></script>
<link rel='shortlink' href='https://tidbits.com/?p=33709' />

<script type="text/javascript">
<!--
function bb2_addLoadEvent(func) {
	var oldonload = window.onload;
	if (typeof window.onload != 'function') {
		window.onload = func;
	} else {
		window.onload = function() {
			oldonload();
			func();
		}
	}
}

bb2_addLoadEvent(function() {
	for ( i=0; i < document.forms.length; i++ ) {
		if (document.forms[i].method == 'post') {
			var myElement = document.createElement('input');
			myElement.setAttribute('type', 'hidden');
			myElement.name = 'bb2_screener_';
			myElement.value = '1532593935 173.245.52.121 52.90.98.148, 173.245.52.121';
			document.forms[i].appendChild(myElement);
		}
	}
});
// --></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-276924-3"></script>
<script>
		window.dataLayer = window.dataLayer || [];
		function gtag(){dataLayer.push(arguments);}
		gtag('js', new Date());
		gtag('config', 'UA-276924-3');
	</script>
</head>
<body class="post-template-default single single-post postid-33709 single-format-standard pmpro-body-has-access">
<header class="o-wrapper c-header">
<a href="#content" class="c-header__skip-link">Skip to content</a>
<div class="c-header__branding">
<a href="https://tidbits.com" rel="home" class="c-header__logo">
<span class="u-hidden-visually">TidBITS</span>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 632 152" width="200" height="45" fill-rule="evenodd"><title>TidBITS</title><path d="M258 2v137c0 4-3 8-8 8h-22v-11l-2 2-5 5c-7 5-15 7-25 7-29 0-50-22-50-54 0-31 21-54 50-54 12 0 21 4 30 12V10c0-5 3-8 8-8h24zM128 147h-24V50c0-4 3-8 8-8h24v97c0 4-3 8-8 8zM111 2L94 31c-2 2-4 4-7 4H67v112H38c-4 0-8-4-8-9V35H1V11c0-5 4-9 9-9h101zm63 94c0-15 11-25 26-25s26 10 26 25-11 26-26 26-26-11-26-26z" fill="#303030" /><path d="M555 100c5 0 8 3 9 7 2 8 7 12 14 12 8 0 14-6 14-13s-4-12-15-16a471 471 0 0 1-34-17c-9-7-14-18-14-30 0-24 22-42 50-42 16 0 30 6 39 16 7 8 9 14 10 28h-30c-4 0-7-2-8-5-2-6-6-8-12-8-7 0-13 4-13 10s4 11 13 15l17 8c24 11 34 22 34 41 0 28-19 44-50 44-33 0-53-17-53-45v-5h29zm-134 47h-28c-5 0-9-4-9-9V10c0-4 4-8 8-8h29v145zm-106 0h-38c-5 0-8-4-8-8V2h45c24 0 33 2 41 8 8 7 13 18 13 30 0 13-6 23-16 29 15 5 24 17 24 34 0 12-5 23-14 31-11 10-20 13-47 13zm170 0h-28V35h-26V2h106l-17 29c-1 2-4 4-7 4h-19v103c0 5-4 9-9 9zM304 88v26h18c12 0 18-5 18-13 0-9-6-13-18-13h-18zm2-53v22h13c11 0 16-4 16-12 0-7-5-10-16-10h-13zM138 4V2h-2c-1 0-15 0-23 9-7 9-5 23-5 24v2h2c1 0 15 0 23-9 7-9 5-24 5-24z" fill="#80298e" /></svg>
</a>
<div class="c-header__tagline">
Thoughtful, detailed coverage of everything Apple for 28 years<br> and the <a href="https://tcn.tidbits.com/apple-pros/">TidBITS Content Network</a> for Apple professionals
</div>
</div>
<button type="button" class="c-header__toggle" data-toggle="drawer">
<span class="u-hidden-visually">Menu</span>
</button>
<div id="drawer" class="c-header__drawer">
<div class="c-header__search">
<form role="search" method="get" id="searchform" action="https://tidbits.com" class="c-form c-search">
<div class="c-form__field c-form__field--inplace c-search__field js-inplace">
<input type="text" name="s" id="header-search" value="" class="c-form__input c-search__input">
<label for="header-search" class="c-form__label c-search__label">Enter Search</label>
</div>
<button type="submit" class="c-btn-unstyled c-form__button c-search__submit">
<svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 32 32"><title>Search</title><path d="M31 27.2l-7.6-6.4c-.8-.7-1.6-1-2.3-1a12 12 0 1 0-1.3 1.3c0 .7.3 1.5 1 2.3l6.4 7.6c1.1 1.2 3 1.3 4 .2s1-2.9-.2-4zM12 20a8 8 0 1 1 0-16 8 8 0 0 1 0 16z" /></svg>
</button>
</form>
</div>
<div class="c-header__links">
<a href="/login/" class="c-btn-unstyled c-header__link" data-toggle="header-login-form">Log In</a>
<div id="header-login-form" class="c-header__login">
<form class="c-form c-login" method="post" action="https://tidbits.com/wp/wp-login.php">
<input type="hidden" name="action" value="login">
<input type="hidden" name="rememberme" value="forever">
<div class="c-form__field">
<label for="login-username" class="c-form__label">Username or Email Address</label>
<input id="login-username" class="c-form__input" type="text" name="log" autocomplete="username email">
</div>
<div class="c-form__field">
<label for="login-password" class="c-form__label">Password</label>
<input id="login-password" class="c-form__input" type="password" name="pwd" autocomplete="current-password">
</div>
<div class="c-form__buttons">
<button class="c-btn c-btn--primary" type="submit">Log In</button>
<a href="https://tidbits.com/wp/wp-login.php?action=lostpassword" class="c-form__link">Forgot password?</a>
</div>
</form>
</div>
</div>
<nav class="c-nav c-nav--decorated c-header__nav">
<ul class="c-nav__list">
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25068 menu-item-has-children c-nav__item">
<button class="c-nav__link">Weekly Issues</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-33660 c-nav__subitem">
 <a href="https://tidbits.com/issues/1426/" class="c-nav__sublink">#1426: APFS explained, TwelveSouth's AirFly for AirPods, Internet services for researching used cars</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-33546 c-nav__subitem">
<a href="https://tidbits.com/issues/1425/" class="c-nav__sublink">#1425: New MacBook Pros, the App Store's impact after 10 years, Eufy BodySense smart scale</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-33418 c-nav__subitem">
<a href="https://tidbits.com/issues/1424/" class="c-nav__sublink">#1424: Apple OS updates, Compare edits in Photos, Velop Wi-Fi mesh, Google PhotoScan, Resetting lost admin passwords</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-33339 c-nav__subitem">
<a href="https://tidbits.com/issues/1423/" class="c-nav__sublink">#1423: Finder batch renaming, WhenWorks scheduling app, CE Week gadgets</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-33205 c-nav__subitem">
<a href="https://tidbits.com/issues/1422/" class="c-nav__sublink">#1422: Apple to fix MacBook keyboards, 911 location sharing, Xmarks gone, Web pages by email, Honeywell Lyric and HomeKit</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25142 c-nav__subitem">
<a href="/issues/" class="c-nav__sublink">All Back Issues</a>
</li>
</ul>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25145 menu-item-has-children c-nav__item">
<button class="c-nav__link">Membership</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21762 c-nav__subitem">
<a href="https://tidbits.com/membership/benefits/" class="c-nav__sublink">Benefits</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-25077 c-nav__subitem">
<a href="https://tidbits.com/membership/levels/" class="c-nav__sublink">Join TidBITS!</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-28753 c-nav__subitem">
<a href="https://tidbits.com/members/" class="c-nav__sublink">TidBITS Members</a>
</li>
</ul>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25094 menu-item-has-children c-nav__item">
<button class="c-nav__link">Get TidBITS</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-25102 c-nav__subitem">
<a href="https://tidbits.com/mailing-lists/" class="c-nav__sublink">Email</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-30771 c-nav__subitem">
<a href="https://apple.news/TjCWZPx-CS2u2x6rWr-PwkQ" class="c-nav__sublink">Apple News</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25100 c-nav__subitem">
<a href="http://www.facebook.com/pages/TidBITS/195314925519" class="c-nav__sublink">Facebook</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25098 c-nav__subitem">
<a href="http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=276986548" class="c-nav__sublink">Podcast</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25097 c-nav__subitem">
<a href="https://tidbits.com/feed/" class="c-nav__sublink">RSS</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25099 c-nav__subitem">
<a href="http://www.twitter.com/TidBITS" class="c-nav__sublink">Twitter</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-28764 c-nav__subitem">
<a href="http://slackbits.herokuapp.com/" class="c-nav__sublink">🗣 SlackBITS</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-28765 c-nav__subitem">
<a href="https://talk.tidbits.com/c/tidbits-talk" class="c-nav__sublink">🗣 TidBITS Talk</a>
</li>
</ul>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25146 menu-item-has-children c-nav__item">
<button class="c-nav__link">Categories</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29406 c-nav__subitem">
<a href="https://tidbits.com/category/aapl/" class="c-nav__sublink">Apple Inc.</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29407 c-nav__subitem">
<a href="https://tidbits.com/category/apple-tv/" class="c-nav__sublink">Apple TV</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21728 c-nav__subitem">
<a href="https://tidbits.com/category/apple-watch/" class="c-nav__sublink">Apple Watch</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29408 c-nav__subitem">
<a href="https://tidbits.com/category/enterprise/" class="c-nav__sublink">Enterprise</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21732 c-nav__subitem">
<a href="https://tidbits.com/category/entertainment/" class="c-nav__sublink">Entertainment</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28402 c-nav__subitem">
<a href="https://tidbits.com/category/automation/" class="c-nav__sublink">Home Automation</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21735 c-nav__subitem">
<a href="https://tidbits.com/category/inside/" class="c-nav__sublink">Inside TidBITS</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21736 c-nav__subitem">
<a href="https://tidbits.com/category/ios/" class="c-nav__sublink">iPhone, iPad, & iOS</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21737 c-nav__subitem">
<a href="https://tidbits.com/category/fun/" class="c-nav__sublink">Just for Fun</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-21739 c-nav__subitem">
<a href="https://tidbits.com/category/mac/" class="c-nav__sublink">Mac & macOS</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25093 c-nav__subitem">
<a href="/watchlist" class="c-nav__sublink">Mac App Updates</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21740 c-nav__subitem">
<a href="https://tidbits.com/category/creative/" class="c-nav__sublink">Media Creation</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21743 c-nav__subitem">
<a href="https://tidbits.com/category/net/" class="c-nav__sublink">Networking</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21744 c-nav__subitem">
<a href="https://tidbits.com/category/opinion/" class="c-nav__sublink">Opinion</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21748 c-nav__subitem">
<a href="https://tidbits.com/category/problem-solving/" class="c-nav__sublink">Problem Solving</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21729 c-nav__subitem">
<a href="https://tidbits.com/category/productivity/" class="c-nav__sublink">Productivity</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21747 c-nav__subitem">
<a href="https://tidbits.com/category/security/" class="c-nav__sublink">Security</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21749 c-nav__subitem">
<a href="https://tidbits.com/category/tech/" class="c-nav__sublink">Tech News</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25214 c-nav__subitem">
<a href="https://tidbits.com/category/tip/" class="c-nav__sublink">Tip</a>
</li>
</ul>
</li>
</ul>
</nav>
</div>
</header>
<main id="content" class="o-wrapper o-wrapper--narrow" tabindex="-1">
<article id="post-33709" class="c-post">
<div class="c-post__thumb-wrapper">
<img src="https://tidbits.com/wp/../uploads/2018/07/Hard-drive-and-an-SSD-900x0-c-default.jpg" srcset="https://tidbits.com/wp/../uploads/2018/07/Hard-drive-and-an-SSD-900x0-c-default.jpg 900w, https://tidbits.com/wp/../uploads/2018/07/Hard-drive-and-an-SSD-1800x0-c-default.jpg 1800w" alt="A laptop hard drive next to an SSD." class="c-post__thumb">
<span class="c-post__thumb-credit"><p>Photo by Jeff Carlson</p>
</span>
<header class="c-post__header has-thumbnail">
<a href="https://tidbits.com/author/jeff-carlson/" class="c-post__author" style="background-color:#b55d1b">Jeff Carlson</a>
<time pubdate="pubdate" datetime="2018-07-23T13:55:06+00:00" class="c-post__date">
23 July 2018
</time>
<a href="#discussion" class="c-post__comments">
8
comments
</a>
<h1 class="c-post__title">What APFS Does for You, and What You Can Do with APFS</h1>
</header>
</div>
<div class="c-post__content">
<div class="c-post__sharing js-sticky">
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><h3 class="sd-title">Share</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-33709" class="share-facebook sd-button no-icon" href="https://tidbits.com/2018/07/23/what-apfs-does-for-you-and-what-you-can-do-with-apfs/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-33709" class="share-twitter sd-button no-icon" href="https://tidbits.com/2018/07/23/what-apfs-does-for-you-and-what-you-can-do-with-apfs/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button no-icon" href="https://tidbits.com/2018/07/23/what-apfs-does-for-you-and-what-you-can-do-with-apfs/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
</div>
<p>When Apple released macOS 10.13 High Sierra in 2017, one of its most notable features was nearly invisible. Installing the update on a Mac with a solid-state drive (SSD)—but not a Fusion drive—automatically switched the underlying file system from Mac OS Extended (also known as HFS+) to APFS (Apple File System).</p>
<p>The file system is the bedrock-level technology that specifies where data is stored—not just in terms of how files and folders are represented in the operating system, but where individual bits are physically stored in the cells of an SSD chip or on the magnetic surfaces of the spinning platters in a mechanical hard disk drive.</p>
<p>There are any number of ways the switch to APFS could have gone wrong, but for most people the shift was seamless—if a bit more time consuming than most macOS upgrades. You may not even have noticed that your Mac is now running APFS. To find out, open Disk Utility, click your startup disk in the sidebar, and look under the disk name.</p>
<p><a href="https://tidbits.com/wp/../uploads/2018/07/Disk-Utillity-APFS.png"><img class="aligncenter size-large wp-image-33713" src="https://tidbits.com/wp/../uploads/2018/07/Disk-Utillity-APFS-640x362.png" alt="Using Disk Utility to identify the file system of the selected startup disk with a highlight showing that it’s APFS." width="640" height="362" /></a></p>
<p>High Sierra converted my 2016 MacBook Pro when I upgraded and, since nothing blew up, I filed APFS away as another technology shift that Apple managed efficiently. But in the process of writing my just-released book <em><a href="https://www.takecontrolbooks.com/digital-storage?aff=AFL5392537175&amp;pt=TIDBITS">Take Control of Your Digital Storage</a></em>, I learned why Apple went to all the trouble. APFS offers a few notable automatic benefits and some useful things you can do directly.</p>
<h2>What Does APFS Do for Me?</h2>
<p>Let’s start with why Apple made the switch from Mac OS Extended to APFS in the first place. Although mechanical hard disk drives are still widely used and offer the best price per gigabyte, solid-state storage media is the future. (In fact, APFS is the file system used by iOS devices, Apple Watches, and Apple TVs—all of which store data in solid-state memory.) An SSD provides much faster performance because it doesn’t suffer from the lag between macOS asking for data and a mechanical disk’s armature skipping to the correct positions on the platters to read it. An SSD also has no moving parts, so the likelihood of mechanical failure is extremely low.</p>
<p>However, the file system in use before APFS, Mac OS Extended, isn’t as efficient when working with SSDs. It was designed—many years ago—with magnetic disks in mind, where a file is preferably written in a long stretch across the surface. In reality, most files are split up into many tiny pieces, which is why we used to optimize performance by “defragmenting” disks, a practice largely unneeded these days except in rare circumstances.</p>
<p>On an SSD, data is written to cells regardless of where they are located in relation to one another. But there’s a catch: data can be written to the cells only a finite number of times, so APFS efficiently shuffles data around to manage SSD wear. Also, if you duplicate a file on an SSD, APFS uses the stored data of the original file and writes just the changes rather than writing an entirely new file. In terms of performance that you can see, duplicating that file—or folder, or hundreds of files—happens nearly instantaneously because APFS makes metadata links to the originals.</p>
<p>So, underneath the surface, APFS handles data more efficiently. That said, Apple is still working on APFS, making it a moving target for developers of backup and disk utility software and limiting the compatibility of the file system. APFS currently works only with SSDs, although Apple says that full support for mechanical hard disks and Fusion drives is coming in macOS 10.14 Mojave. It’s possible to format a hard disk drive as APFS, but you’re likely to <a href="https://blog.macsales.com/43043-using-apfs-on-hdds-and-why-you-might-not-want-to">experience a performance hit</a> compared to it formatted with Mac OS Extended. It will be interesting to see how Apple addresses that in Mojave.</p>
<p>APFS also isn’t supported on Time Machine drives. Even if your startup disk is an SSD, your Time Machine drive needs to remain in Mac OS Extended format for the time being.</p>
<h2>What Can I Do with APFS?</h2>
<p>That’s all behind-the-scenes stuff, but what does APFS enable you to do? One of its most powerful user-facing features is how it enables you to create multiple, resizable volumes on your drive. Sometimes people want to split a drive into multiple virtual volumes to separate data such as files for work and files for home or to encrypt one for storing sensitive data and leave the other unencrypted.</p>
<p>To explain how Mac OS Extended and APFS each handle that task, imagine the drive is a factory that builds rockets. I could instead use an office building as a metaphor, but wouldn’t you rather visualize spaceships?</p>
<p>On a drive formatted as Mac OS Extended, the factory is a giant open space where the rockets can be assembled and parts can be stacked. The factory floor is the free space on the drive.</p>
<p>(There’s also a secret door to a hidden room of emergency equipment that nobody pays attention to unless something goes wrong on the factory floor. That room represents macOS Recovery, the invisible startup partition that runs a scaled-down version of the operating system when you need to repair your main macOS installation.)</p>
<p>Now, let’s say you want to partition the drive into two volumes or, in our example, to split the factory into two sections to build two rockets simultaneously. Under Mac OS Extended, you’d erect a permanent wall between the sections, creating two separate rooms. (The hidden macOS Recovery room is still there, too. Safety first, people.)</p>
<p>Soon your rocket business is growing quickly, and you realize you need to build a larger rocket that will get a spacecraft to Mars. The problem is, this new rocket won’t fit into either of the two rooms. So, to make way for it, you have to take everything out of the factory (back up all the data and erase the volume), smash the wall (reformat the drive), build a brand-new wall that allocates enough space for the large rocket and leaves a smaller second room for the first rocket design and components (repartition the drive), and put everything back (restore the data from backup).</p>
<p>(Technically, there’s another option. If one of the rooms (partitions) is empty, Mac OS Extended enables engineers to move the wall, resizing the partition non-destructively. But when there’s equipment (data) in each room, the wall has to come down first.)</p>
<p>If, instead, you decide to go back to the one-room layout, you need to take everything out of both rooms and start over (back up all the data, erase the entire drive, and restore the data).</p>
<p>Now, let’s look at an APFS-powered rocket factory.</p>
<p>In terms of how space is allocated when formatting or partitioning a drive, APFS creates containers that include volumes, which can be dynamically adjusted as needed.</p>
<p>In our rocket factory analogy, APFS starts as a large open building, but even before a single piece of machinery is installed, a border of bright yellow-and-black tape is put onto the floor to indicate the active work area. That’s the container, and it encompasses nearly all of the factory area. That large area is also a single volume.</p>
<p>(If the drive is a startup disk, there are two other small areas taped off, one for the macOS Recovery room, and one for virtual memory, basically a small spot to store equipment—data—for short periods of time to make it easier to access.)</p>
<p>In this scheme, all the space in the volume is available for use, just as in the Mac OS Extended factory, but the factory manager is better about positioning tools and equipment near each other for a more efficient workflow.</p>
<p>As production ramps up and the factory floor needs to split into two sections, the APFS factory doesn’t build a physical wall. Instead, the manager merely moves the tape to indicate that there are now two work areas: adding a new volume and making the original volume smaller. The equipment in the area that becomes the second work area moves as needed—rather than being removed (erased) to create the volume. (You can also set minimum and maximum size limits for a container when you create it.) In the Finder, you see two volumes.</p>
<p><a href="https://tidbits.com/wp/../uploads/2018/07/Disk-Utility-split-volume.png"><img class="aligncenter size-large wp-image-33714" src="https://tidbits.com/wp/../uploads/2018/07/Disk-Utility-split-volume-640x359.png" alt="An external SSD in Disk Utility has been split into two volumes." width="640" height="359" /></a></p>
<p>When the order comes in to start manufacturing bigger rockets, the volume that needs the extra space automatically grows as needed: redrawing the taped area and taking space from the second volume dynamically. No walls need to be torn down; no volumes need to be erased and then restored.</p>
<p>(Note that it is possible to partition an APFS drive, which gives you multiple immovable containers, but then they have the same limitations as Mac OS Extended partitions. So there isn’t much point.)</p>
<h2>APFS Snapshots</h2>
<p>Another major benefit to APFS is its support for snapshots, which are a record of a drive’s state at a point in time. When you apply a system update, macOS automatically creates a new snapshot, so if anything goes wrong, you can roll the Mac back to the exact state it was in before the update. A snapshot is also created once every hour. These snapshots also enable you to retrieve deleted files or to go back to an earlier version of a file.</p>
<p>Sound familiar? Except for the automatic pre-update backup, that’s how Time Machine works. In fact, to access snapshots, you use the Time Machine interface (even if you haven’t yet set up Time Machine). But two separate things are going on behind the scenes.</p>
<p>When a Time Machine drive is connected, macOS makes regular Time Machine backups, not APFS snapshots, to that drive. Since a Time Machine drive must be formatted as Mac OS Extended, macOS copies to the drive any files that were changed since the last backup.</p>
<p>If the Time Machine drive is not connected—let’s say you’re traveling with your MacBook Pro—macOS creates APFS snapshots every hour and stores them on the startup disk or any APFS-formatted SSD directly connected to the Mac. The snapshots don’t take up much extra space, because they only contain metadata describing the states and locations of every file, plus data that&#8217;s been removed or replaced. Snapshots also age out after 24 hours and are automatically deleted.</p>
<p>On Macs running macOS versions earlier than High Sierra or those with hard disk drives or Fusion drives still formatted as Mac OS Extended, Time Machine creates similar local “mobile Time Machine” snapshots when the Time Machine drive is disconnected. But because the drive isn’t formatted as APFS, those local snapshots are not the same as APFS snapshots.</p>
<p>On a drive formatted as APFS, you can see how many snapshots are present by opening the Terminal app and typing:</p>
<p><code>tmutil listlocalsnapshots /</code></p>
<p>You can also create a snapshot at any time by typing:</p>
<p><code>tmutil snapshot</code></p>
<p>If you need to restore deleted files or go back to an earlier version of a file, you use the Time Machine interface to do it. Click the Time Machine icon in the Dock or choose Enter Time Machine from the Time Machine menu bar icon, and then use the timeline on the right to navigate to the version of the file you want.</p>
<p><a href="https://tidbits.com/wp/../uploads/2018/07/Past-snapshots-Time-Machine.png"><img class="aligncenter size-large wp-image-33715" src="https://tidbits.com/wp/../uploads/2018/07/Past-snapshots-Time-Machine-640x380.png" alt="Browsing past snapshots in the Time Machine interface." width="640" height="380" /></a></p>
<p>Should you need to restore the entire startup disk to a previous state, restart into macOS Recovery (hold Command-R at startup until you see the macOS Utilities screen), and choose Restore from Time Machine. You’ll be given the option to select one of the local snapshots.</p>
<p><a href="https://tidbits.com/wp/../uploads/2018/07/Restore-snapshot.png"><img class="aligncenter size-large wp-image-33716" src="https://tidbits.com/wp/../uploads/2018/07/Restore-snapshot-640x476.png" alt="Viewing saved snapshots in the Time Machine interface of the macOS Utilities app." width="640" height="476" srcset="https://tidbits.com/wp/../uploads/2018/07/Restore-snapshot-640x476.png 640w, https://tidbits.com/wp/../uploads/2018/07/Restore-snapshot.png 860w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p>(Speaking of macOS Recovery, if you open Disk Utility and run First Aid on the startup disk, it also checks all the snapshots. So if you have a lot, be prepared to wait quite some time for First Aid to complete.)</p>
<p>You may never need to take advantage of snapshots, but it’s comforting to know that macOS has a built-in data protection mechanism in place at the file-system level.</p>
<h2>Take Control of Your Digital Storage</h2>
<p>APFS is just one part of our modern storage picture. In <a href="https://www.takecontrolbooks.com/digital-storage?aff=AFL5392537175&amp;pt=TIDBITS"><em>Take Control of Your Digital Storage</em>,</a> I also investigate the other acronyms that bedevil us when contemplating adding capacity: what to look for when buying a NAS (Network-Attached Storage), understanding the difference between HDDs (hard disk drives) and SSDs (solid-state drives), and explaining RAID (Redundant Array of Independent Disks) and, related to RAID, possibly my favorite acronym ever, JBOD (just a bunch of disks). You’ll also learn more about creating partitions and volumes, using Disk Utility and First Aid, encrypting drives and data, and more.</p>
<p>The book is <a href="https://www.takecontrolbooks.com/digital-storage?aff=AFL5392537175">available now for $12.99</a> at the Take Control bookstore.</p>
</div>
</article>
<div class="c-banner c-banner--success c-cta">
<div id="sendgrid_mc_email_subscribe">
<h2 class="h4">Subscribe today so you don’t miss any TidBITS articles!</h2>
<p>Every week you’ll get tech tips, in-depth reviews, and insightful news analysis for discerning Apple users. For 28 years, we’ve published professional, member-supported tech journalism that makes you smarter. </p>
<form action="/wp/wp-login.php?action=register" method="post" class="c-form c-form--inline">
<div class="c-form__field c-form__field--inplace js-inplace">
<input type="email" name="user_email" id="cta-signup-email" class="c-form__input">
<label for="cta-signup-email" class="c-form__label">Email Address</label>
</div>
<input type="hidden" name="user_issue_subscription" value="1">
<button type="submit" class="c-btn c-btn--primary c-btn--small">Subscribe</button>
</form>
<p>Registration confirmation will be emailed to you.</p>
</div>
</div>
<aside class="o-wrapper__breakout c-ad c-ad--image" data-ad-campaign="Backblaze Sponsorship - backblaze-unlimited-backup-2018-04">
<div class="c-ad__inner">
<a href="https://www.backblaze.com/tb"><picture><source srcset="https://tidbits.com/wp/../uploads/2018/01/backblaze-ad-20180326-640x200.jpg" media="(max-width: 600px)" type="image/jpeg"><img src="https://tidbits.com/wp/../uploads/2018/01/backblaze-ad-20180326-1456x180.jpg" srcset="https://tidbits.com/wp/../uploads/2018/01/backblaze-ad-20180326-1456x180.jpg 1456w, https://tidbits.com/wp/../uploads/2018/01/backblaze-ad-20180326-1456x180-644x80.jpg 644w" alt="Backblaze: Online backup with unlimited data. $5/Month. 15 Day Free Trial!"></picture></a>
</div>
</aside>
<aside id="related-articles" class="o-wrapper__breakout">
<div class="c-posts-callout">
<div class="c-post__terms">
<a href="https://tidbits.com/category/mac/" class="c-badge">Mac &amp; macOS</a>
<a href="https://tidbits.com/tag/apfs/" class="c-badge">APFS</a>
<a href="https://tidbits.com/tag/fusion-drive/" class="c-badge">Fusion Drive</a>
<a href="https://tidbits.com/tag/hard-disk/" class="c-badge">hard disk</a>
<a href="https://tidbits.com/tag/ssd/" class="c-badge">SSD</a>
<a href="https://tidbits.com/tag/storage/" class="c-badge">storage</a>
</div>
</div>
</aside>
<section id="discussion" class="c-comments">
<h2 class="c-comments__title">
<span class="u-size-small">Comments About</span>
What APFS Does for You, and What You Can Do with APFS
</h2>
<div id="comments" class="comments-area discourse-comments-area">
<h2 class="comments-title discourse-comments-title">Notable Replies</h2>
<ol class="comment-list"> <li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/calion/64/1841_1.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">Jim Syler</a></b>
</div>
<div class="comment-metadata">
<time datetime="23 July 2018">23 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>Are you sure that the default is that snapshots are created each hour? I have no snapshots on my disk (well, I didn’t until I manually created one), and other Internet sources seem to indicate that they are only automatically created before major system updates.</p></div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/stevej1/64/241_1.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">Steve Johgart</a></b>
</div>
<div class="comment-metadata">
<time datetime="23 July 2018">23 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>I was hoping this article would clarify the somewhat annoying behavior I’ve encountered. I purchased a (spinning platter) external drive and reformatted it as APFS (not knowing that might not be a good idea). In the process I partitioned it into two partitions. Now both partitions show up on my desktop and seem to work fine and show the capacity I intended for each - but the original volume also shows up on my desktop, still showing the full capacity of the unpartitioned original drive. I’m concerned that I’ll accidentally copy something to that original volume and in the process screw up my partitions - is there a way to make that original drive go away (at least not appear on the desktop)?</p></div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/alvarnell/64/464_1.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">Al Varnell</a></b>
</div>
<div class="comment-metadata">
<time datetime="24 July 2018">24 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>It’s much less than not a good idea, it’s unsupported by Apple and severely limits what the drive can be used for.</p>
<p>Paragon provides a lossless converter. Have not tried it myself, but they have a solid reputation.</p>
<p><a href="https://www.paragon-software.com/home/apfs-hfs-converter/" rel="nofollow noopener">https://www.paragon-software.com/home/apfs-hfs-converter/</a></p>
<p>-Al-</p>
</div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/jeffc/64/20_1.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">Jeff Carlson</a></b>
</div>
<div class="comment-metadata">
<time datetime="24 July 2018">24 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>Good question, Jim. There’s some confusion about this. I was looking at <a href="https://support.apple.com/en-us/HT204015" rel="nofollow noopener">this Apple Support article</a> that reads:</p>
<p>" Your Time Machine backup disk might not always be available, so Time Machine also stores some of its backups on your built-in startup drive and other local drives. These backups are called local snapshots. One snapshot is saved every hour. If you’re using macOS High Sierra, another snapshot is saved before installing any <a href="https://support.apple.com/kb/HT201541" rel="nofollow noopener">macOS update</a>."</p>
<p>However, looking at it again, it sounds like that’s just for the HFS+ local Time Machine backups, not APFS local snapshots.</p>
<p>Right now I’m not seeing anything other details, though a tickle in the back of my mind says I did see something more specific at some point. As it is, if I use <code>tmutil listlocalsnapshots /</code> on my machine right now, I see:</p>
<p><code>com.apple.TimeMachine.2018-07-23-014427</code><br><code>com.apple.TimeMachine.2018-07-23-031655</code><br><code>com.apple.TimeMachine.2018-07-23-113908</code><br><code>com.apple.TimeMachine.2018-07-23-123820</code><br><code>com.apple.TimeMachine.2018-07-23-143901</code></p>
<p>I haven’t done any system update checks today (unless maybe those were done in the background, but that seems quite aggressive).</p>
<p>Snapshots also depend on how much free space you have. Also, in the Time Machine pref pane, do you have Back Up Automatically selected? I wonder if that could also trigger the snapshots.</p>
</div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/jeffc/64/20_1.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">Jeff Carlson</a></b>
</div>
<div class="comment-metadata">
<time datetime="24 July 2018">24 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>Steve, I’d say the best approach would be to make a duplicate of those partitions, then format the HDD as Mac OS Extended with new partitions and restore the data. Then you won’t have to wonder.</p>
<p>But your question points to one of the things that inspired this article and my book in the first place. There’s been a jumble of info out there about APFS. And I know that Apple still hasn’t documented everything sufficiently for developers.</p>
</div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/jeff5/64/1521_1.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">B. Jefferson Le Blanc</a></b>
</div>
<div class="comment-metadata">
<time datetime="24 July 2018">24 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>You can install High Sierra on an HDD without the automatic conversion to APFS that you get with an SSD. However, I’ve been test driving the macOS 10.14 Mojave beta and it does automatically convert an HDD to APSF, without asking permission. On a clone of my Sierra system on a HFS+ hard drive Mojave runs slow as snot and often fails to start up at all. I’ve twice been obliged to reinstall the beta just to get it to upgrade to the latest version and then clone it back to an HFS+ partition, at which point it (sometimes) runs better. If it fails one more time I’ll give it up as a bad deal.</p>
<p>As for the destination between partitions and containers, that’s just too complex for this tired old brain to handle.</p>
</div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/tidbits41/64/1554_1.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">paulc</a></b>
</div>
<div class="comment-metadata">
<time datetime="24 July 2018">24 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>Before the launch of HS, there were kinda promises that APFS WOULD work on SSD based RAID arrays. Not a peep from Cupertino since then and try as I might to find out ANY information, nobody seems to know anything, not even speculation! Dummy that I can be at times, never thought to come here…</p>
<p>Been leary to even try and take my Sierra up to HS because I was concerned I’d complete trash my setup in the process… although the theory was that I SHOULD be able to go HS with it not trying to convert to APFS. As time went by, I figured that why not go from to Mohave… so the question remains will Mohave legitimately support arrays (and/or spinning drives), will it try to force convert to APFS and trash my array, or will it give me a choice?</p>
</div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/letter_avatar_proxy/v2/letter/l/7c8e57/64.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478" rel="external" class="url">Richard Fairbanks</a></b>
</div>
<div class="comment-metadata">
<time datetime="24 July 2018">24 July 2018</time>
</div>
</footer>
<div class="comment-content"><p>Does anyone know if Apple has any plans to enable checksums for user data, as opposed to only Apple’s system metadata? Bit rot on user data does need to be addressed.</p>
<p>Blessings, and thank you!</p>
</div>
</article>
</li>
</ol>
<div class="respond comment-respond">
<h3 id="reply-title" class="comment-reply-title">
Join the discussion in <a href="https://talk.tidbits.com/session/sso?return_path=https://talk.tidbits.com/t/what-apfs-does-for-you-and-what-you-can-do-with-apfs/5478">
the TidBITS Discourse forum
</a>
</h3>
<p class="more-replies"></p>
<div class="comment-reply-title">
<h4 class="discourse-participants">Participants</h4>
<p> <img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/jeffc/64/20_1.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/stevej1/64/241_1.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/alvarnell/64/464_1.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/letter_avatar_proxy/v2/letter/l/7c8e57/64.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/jeff5/64/1521_1.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/tidbits41/64/1554_1.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/calion/64/1841_1.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
</p>
</div>
</div>
</div>
<ul class="comment-list">
</ul>
</section>
</main>
<footer class="o-wrapper c-footer">
<div class="c-footer__inner">
<p class="c-footer__copyright o-type-small">
<strong>TidBITS</strong> is copyright © 2018 TidBITS Publishing Inc.
Reuse governed by Creative Commons License.
</p>
<nav class="c-nav c-footer__nav">
<ul class="c-nav__list">
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21698 c-nav__item">
<a href="https://tidbits.com/about/" class="c-nav__link">About</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21697 c-nav__item">
<a href="https://tidbits.com/about/advertise/" class="c-nav__link">Advertise</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-28746 c-nav__item">
<a href="https://tidbits.com/about/code-of-conduct/" class="c-nav__link">Code of Conduct</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21696 c-nav__item">
<a href="https://tidbits.com/about/contact/" class="c-nav__link">Contact</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21695 c-nav__item">
<a href="https://tidbits.com/about/copyright/" class="c-nav__link">Copyright</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21694 c-nav__item">
 <a href="https://tidbits.com/about/privacy/" class="c-nav__link">Privacy Policy</a>
</li>
</ul>
</nav>
<a href="https://madebyneversink.com" class="c-footer__credit">
Design by <svg xmlns="http://www.w3.org/2000/svg" width="102" height="19" viewBox="0 0 518 94"><title>Neversink</title><g fill="#a7630b"><path d="M114.7 45.6c1 2.2 1.6 4.2 2.6 6L119 44c8.5-34 26.6-42.3 39.2-42.3 10.6 0 16 5 16 10 0 3.6-2.5 7-6.5 7-7.7 0-5.7-10.3-14-10.3-7.6 0-19.3 6.2-26.6 29-2 7-4.3 15.6-6.3 23.8 7.7 17.5 14.8 25.7 22 25.7 7.6 0 6.7-11 14.7-11 3.3 0 5.7 2 5.7 5.8 0 6-7.2 11-19 11-16.7 0-30.8-12.4-41.7-43L90 16.7l-4 16.7c-11.3 46.5-36.5 57-57.2 57C11.4 90 1.2 79.2 1.2 66c0-14.7 13.3-23.8 26.7-23.8 12 0 21 6.8 21 14.8 0 3.8-2.6 7-6.7 7-4.8 0-6.2-4-7-8.3-.8-4-2-8.2-9.2-8.2A19 19 0 0 0 7 66.1C7 77 15.4 85 29 85c19 0 41-10 51.3-51.6l4.2-17c1-4.4-.7-5-3.8-6.2-2.5-1-7.8-1.8-14.2-1.8-15 0-21.6 7-21.6 14.8 0 4.4 2.4 8 7 8 7.2 0 5.6-11 13.8-11 3.7 0 5.8 2.8 5.8 6 0 6.5-8 11.6-16.3 11.6-10.6 0-16-6-16-14 0-11 9.4-20.4 28-20.4 11.8 0 17 2.6 27 2.6h5.8l14.4 39.6z" /><path d="M148 45.6c-.6 3-1 6.4-1 9 0 7 3.5 11.6 10.8 11.6 5.7 0 11.3-3.8 15.7-10.4l3.8 2.6c-5.5 8.4-12 13-21 13-12.8 0-20.5-8.2-20.5-18.5 0-16 11.5-26 25-26 11.5 0 19.2 6.4 17.2 18.8h-30v-.2zm1.6-4.7h18.6c1.3-6.5-1.8-9.6-7-9.6-5.8 0-9.4 4.2-11.6 9.5zM193 70l-4.7-31.5c-.7-4.8-1-6.8-4.8-7.3l.7-3H207l-.8 3c-5.7.4-7.5 2-7 6.4l2.8 20 12.8-19.7c3-5 2.4-6.3-2.4-7l.7-2.8h16.5l-.7 3c-3.5.3-5.5 2-8.6 7.2L199.8 70h-7zm45-24.5c-.7 3-1 6.4-1 9 0 7 3.4 11.6 10.7 11.6 5.6 0 11.2-3.8 15.6-10.4l3.7 2.6c-5.5 8.4-12 13-21 13-12.8 0-20.5-8.2-20.5-18.5 0-16 11.5-26 25-26 11.5 0 19.2 6.4 17.2 18.8h-29.8v-.2zm1.5-4.7h18.6c1.3-6.5-1.8-9.6-7-9.6-6 0-9.6 4.2-11.6 9.5zm28.8 29l.7-3.2c4.8-.4 5.8-1.5 6.8-4.4l5.5-22.7c.5-2 0-2.7-1.8-2.7h-3l.6-2.7 14.6-7.5h4l-1.6 6.2c6.8-10.6 17.4-20.6 25.8-20.6 4 0 7 2.2 7 5.7 0 3.4-2.6 5.8-5.7 5.8-3.7 0-3.7-2.2-6.8-2.2-5.8 0-16.4 10.2-23.4 23.6l-4 17.5c-.6 3 0 3.8 4.5 4.4l-.7 3h-22.3z" /><path d="M292.3 75.6c0-7.5 6.6-12 13.7-12 7.7 0 12.6 5.8 18 11.2.6-1.6 1-3.5 1-5 0-15.2-22-14.5-22-29 0-8.8 7.6-14.3 17.6-14.3 6 0 10 1.6 12.6 3.7l1.3-2.2h2.7l1 14.3-2.8.7c-2.7-8.2-7.7-12-13.7-12-4.8 0-8.6 2.5-8.6 6.5 0 9.7 21.8 10 21.8 28.5 0 4.8-2 10-5.8 14 4.2 3.8 9 6.7 16 6.7 7.4 0 5.4-9.7 12.3-9.7 2.4 0 4.4 1.6 4.4 4.2 0 5.7-7 10.2-17 10.2-8.2 0-14.2-3.8-19.2-8.4-4 3-9 5-15.5 5-9.7 0-17.7-4.2-17.7-12.4zm29 3.3c-5-5.4-9.4-10.5-15.4-10.5-5 0-8.3 2.7-8.3 7 0 5.6 5.8 8.3 12.2 8.3a16 16 0 0 0 11.4-5z" /><path d="M338.3 70l.7-3.2c4.7-.4 5.8-1.5 6.8-4.4l5.5-22.7c.6-2 0-2.7-1.8-2.7h-3l.6-2.7 14.7-7.5h4L357 62.4c-.8 3 0 3.8 4.3 4.4l-.7 3h-22.3zM364 6.2c4 0 6.5 3 6.5 6.4 0 3.3-2.7 6.6-7 6.6-4 0-6.5-3-6.5-6.2 0-3.4 2.5-6.7 7-6.7zM398 70l7.2-30c1.3-5-1-7-4.6-7a22 22 0 0 0-10.8 3.3l-6.3 26c-.7 3 0 4 4.4 4.5l-.8 3H365l.6-3c4.8-.4 5.8-1.5 6.8-4.4l5.5-22.7c.4-2 0-2.7-2-2.7h-3l.7-2.7 14.6-7.5h4l-1 4.4a32 32 0 0 1 15-4.4c6 0 13.2 2.2 10.5 13.3l-5.5 22.6c-.7 3 0 3.8 4.4 4.4l-.7 3h-17zm20.8 0l.7-3.2c4.8-.4 5.8-1.5 6.8-4.4l11-45c.5-2 0-2.7-1.8-2.7h-3l.6-2.7 14.7-7.3h4L442 44.2l9.5-7.3c27.2-21.3 39-28.6 52.4-28.6 5.7 0 13 3 13 8.6 0 3-2 5.5-5.4 5.5-6 0-4-7-13-7-8.4 0-18.5 6.5-37.5 20.7l-6.7 5L464.5 62c2 4.2 3.8 5 6.4 5.5l-.8 3H456l-11-21.8-5 3.8-2.6 10.8c-.7 3 0 4 4.4 4.5l-.7 3h-22.4V70h.2z" /></g></svg>
</a>
</div>
</footer>
<script src="https://cdn.polyfill.io/v2/polyfill.min.js?features=Array.from,Array.forEach,Object.assign"></script>
<script src="https://tidbits.com/app/themes/tidbits/scripts/main.js?id=fe52fa210c8478c72f5a" defer="defer"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var discourse = {"url":"https:\/\/talk.tidbits.com"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tidbits.com/app/plugins/wp-discourse/js/comments.js'></script>
<script type='text/javascript'>
var renderInvisibleReCaptcha = function() {

    for (var i = 0; i < document.forms.length; ++i) {
        var form = document.forms[i];
        var holder = form.querySelector('.inv-recaptcha-holder');

        if (null === holder) continue;
		holder.innerHTML = '';

         (function(frm){
			var cf7SubmitElm = frm.querySelector('.wpcf7-submit');
            var holderId = grecaptcha.render(holder,{
                'sitekey': '6LcQSFMUAAAAAO-4itAckqGlBhzt1MSzkfsGRagG', 'size': 'invisible', 'badge' : 'bottomright',
                'callback' : function (recaptchaToken) {
					if((null !== cf7SubmitElm) && (typeof jQuery != 'undefined')){jQuery(frm).submit();grecaptcha.reset(holderId);return;}
					 HTMLFormElement.prototype.submit.call(frm);
                },
                'expired-callback' : function(){grecaptcha.reset(holderId);}
            });

			if(null !== cf7SubmitElm && (typeof jQuery != 'undefined') ){
				jQuery(cf7SubmitElm).off('click').on('click', function(clickEvt){
					clickEvt.preventDefault();
					grecaptcha.execute(holderId);
				});
			}
			else
			{
				frm.onsubmit = function (evt){evt.preventDefault();grecaptcha.execute(holderId);};
			}


        })(form);
    }
};
</script>
<script type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?onload=renderInvisibleReCaptcha&#038;render=explicit'></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"5bb5cae7d5","applicationID":"173865699","transactionName":"ZlEGNUdRWkQAUxJaWF8bJQJBWVtZTkMPXVBdUQ==","queueTime":0,"applicationTime":1184,"atts":"ShYFQw9LSUo=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
