<!DOCTYPE html>
<html class="no-js" lang="en" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<title>BitBar Lets You Put Anything in Your Mac’s Menu Bar - TidBITS</title>
<link rel="stylesheet" property="stylesheet" href="https://tidbits.com/app/themes/tidbits/styles/main.css?id=0344a59131144ae44bd0">
<link rel="stylesheet" property="stylesheet" href="https://tidbits.com/app/themes/tidbits/styles/print.css?id=e8628b0faa034c13a615" media="print">
<meta name="viewport" content="width=device-width, initial-scale=1">
<script>document.documentElement.className = document.documentElement.className.replace('no-js', 'js');</script>
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#80298e">
<meta name="apple-mobile-web-app-title" content="TidBITS">
<meta name="application-name" content="TidBITS">
<meta name="msapplication-TileColor" content="#80298e">
<meta name="theme-color" content="#80298e">

<title>BitBar Lets You Put Anything in Your Mac’s Menu Bar - TidBITS</title>
<meta name="description" content="BitBar is an open-source menu bar app with a rich library of plug-ins that are easy to adapt to your needs. Don’t see what you want? You can even create your own plug-ins!" />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="BitBar Lets You Put Anything in Your Mac’s Menu Bar - TidBITS" />
<meta property="og:description" content="BitBar is an open-source menu bar app with a rich library of plug-ins that are easy to adapt to your needs. Don’t see what you want? You can even create your own plug-ins!" />
<meta property="og:url" content="https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/" />
<meta property="og:site_name" content="TidBITS" />
<meta property="article:publisher" content="http://www.facebook.com/pages/TidBITS/195314925519" />
<meta property="article:published_time" content="2020-06-12T16:57:47+00:00" />
<meta property="article:modified_time" content="2020-06-12T17:02:40+00:00" />
<meta property="og:image" content="https://tidbits.com/wp/../uploads/2020/06/BitBar-6-640x166.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@jcenters" />
<meta name="twitter:site" content="@TidBITS" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://tidbits.com/#organization","name":"TidBITS Publishing Inc.","url":"https://tidbits.com/","sameAs":["http://www.facebook.com/pages/TidBITS/195314925519","https://www.youtube.com/channel/UC6FJi0g8Dc8Ou3D1YmW8nCA","https://twitter.com/TidBITS"],"logo":{"@type":"ImageObject","@id":"https://tidbits.com/#logo","inLanguage":"en-US","url":"https://tidbits.com/wp/../uploads/2018/02/TidBITS_Logo_Final.png","width":2007,"height":516,"caption":"TidBITS Publishing Inc."},"image":{"@id":"https://tidbits.com/#logo"}},{"@type":"WebSite","@id":"https://tidbits.com/#website","url":"https://tidbits.com/","name":"TidBITS","description":"Thoughtful, detailed coverage of everything Apple for 30 years&lt;br&gt; and the &lt;a href=&quot;https://tcn.tidbits.com/apple-pros/&quot;&gt;TidBITS Content Network&lt;/a&gt; for Apple professionals","publisher":{"@id":"https://tidbits.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://tidbits.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#primaryimage","inLanguage":"en-US","url":"https://tidbits.com/wp/../uploads/2020/06/BitBar-6.png","width":1999,"height":519,"caption":"The Add to BitBar button in context."},{"@type":"WebPage","@id":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#webpage","url":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/","name":"BitBar Lets You Put Anything in Your Mac\u2019s Menu Bar - TidBITS","isPartOf":{"@id":"https://tidbits.com/#website"},"primaryImageOfPage":{"@id":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#primaryimage"},"datePublished":"2020-06-12T16:57:47+00:00","dateModified":"2020-06-12T17:02:40+00:00","description":"BitBar is an open-source menu bar app with a rich library of plug-ins that are easy to adapt to your needs. Don\u2019t see what you want? You can even create your own plug-ins!","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/"]}]},{"@type":"Article","@id":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#article","isPartOf":{"@id":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#webpage"},"author":{"@id":"https://tidbits.com/#/schema/person/cf8c738a886b25ca314aee47fe11cfaf"},"headline":"BitBar Lets You Put Anything in Your Mac\u2019s Menu Bar","datePublished":"2020-06-12T16:57:47+00:00","dateModified":"2020-06-12T17:02:40+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#webpage"},"publisher":{"@id":"https://tidbits.com/#organization"},"image":{"@id":"https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#primaryimage"},"keywords":"AppleScript,scripting,Terminal","articleSection":"Productivity","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/#respond"]}]},{"@type":["Person"],"@id":"https://tidbits.com/#/schema/person/cf8c738a886b25ca314aee47fe11cfaf","name":"Josh Centers","image":{"@type":"ImageObject","@id":"https://tidbits.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/37fe9dce47fa49478fecb3b1667a605a?s=96&d=retro&r=g","caption":"Josh Centers"},"description":"Josh Centers is the managing editor of TidBITS, as well as the author of Take Control of iOS 13 and iPadOS 13, Take Control of Notes, Take Control of Apple Home Automation, and Take Control of Apple TV, and co-author of Take Control of Preview. He's also a contributor to The Prepared and USA TODAY.","sameAs":["https://twitter.com/jcenters"]}]}</script>

<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="TidBITS &raquo; Feed" href="https://tidbits.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="TidBITS &raquo; Comments Feed" href="https://tidbits.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="TidBITS Podcast" href="https://tidbits.com/feed/podcast/" />
<link rel="alternate" type="application/rss+xml" title="TidBITS &raquo; BitBar Lets You Put Anything in Your Mac’s Menu Bar Comments Feed" href="https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/feed/" />
<link rel='stylesheet' id='wp-block-library-css' href='https://tidbits.com/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='comment_styles-css' href='https://tidbits.com/app/plugins/wp-discourse/lib/../css/comments.css?ver=1571179324' type='text/css' media='all' />
<link rel='stylesheet' id='eu-cookie-law-style-css' href='https://tidbits.com/app/plugins/jetpack/modules/widgets/eu-cookie-law/style.css?ver=20170403' type='text/css' media='all' />
<link rel='shortlink' href='https://tidbits.com/?p=46150' />

<style type="text/css">
.sfs-subscriber-count, .sfs-count, .sfs-count span, .sfs-stats { -webkit-box-sizing: initial; -moz-box-sizing: initial; box-sizing: initial; }
.sfs-subscriber-count { width: 88px; overflow: hidden; height: 26px; color: #424242; font: 9px Verdana, Geneva, sans-serif; letter-spacing: 1px; }
.sfs-count { width: 86px; height: 17px; line-height: 17px; margin: 0 auto; background: #ccc; border: 1px solid #909090; border-top-color: #fff; border-left-color: #fff; }
.sfs-count span { display: inline-block; height: 11px; line-height: 12px; margin: 2px 1px 2px 2px; padding: 0 2px 0 3px; background: #e4e4e4; border: 1px solid #a2a2a2; border-bottom-color: #fff; border-right-color: #fff; }
.sfs-stats { font-size: 6px; line-height: 6px; margin: 1px 0 0 1px; word-spacing: 2px; text-align: center; text-transform: uppercase; }
</style>
<style type='text/css'>img#wpstats{display:none}</style>
<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
		ga('create', 'UA-276924-3', 'auto');
		ga('send', 'pageview', {
			'dimension1': '',
			'dimension2': 'Josh Centers',
			'dimension3': 'no'
		});
	</script>
</head>
<body class="post-template-default single single-post postid-46150 single-format-standard pmpro-body-has-access">
<header class="o-wrapper c-header">
<a href="#content" class="c-header__skip-link">Skip to content</a>
<div class="c-header__branding">
<a href="https://tidbits.com" rel="home" class="c-header__logo">
<span class="u-hidden-visually">TidBITS</span>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 632 152" width="200" height="45" fill-rule="evenodd"><title>TidBITS</title><path d="M258 2v137c0 4-3 8-8 8h-22v-11l-2 2-5 5c-7 5-15 7-25 7-29 0-50-22-50-54 0-31 21-54 50-54 12 0 21 4 30 12V10c0-5 3-8 8-8h24zM128 147h-24V50c0-4 3-8 8-8h24v97c0 4-3 8-8 8zM111 2L94 31c-2 2-4 4-7 4H67v112H38c-4 0-8-4-8-9V35H1V11c0-5 4-9 9-9h101zm63 94c0-15 11-25 26-25s26 10 26 25-11 26-26 26-26-11-26-26z" fill="#303030" /><path d="M555 100c5 0 8 3 9 7 2 8 7 12 14 12 8 0 14-6 14-13s-4-12-15-16a471 471 0 0 1-34-17c-9-7-14-18-14-30 0-24 22-42 50-42 16 0 30 6 39 16 7 8 9 14 10 28h-30c-4 0-7-2-8-5-2-6-6-8-12-8-7 0-13 4-13 10s4 11 13 15l17 8c24 11 34 22 34 41 0 28-19 44-50 44-33 0-53-17-53-45v-5h29zm-134 47h-28c-5 0-9-4-9-9V10c0-4 4-8 8-8h29v145zm-106 0h-38c-5 0-8-4-8-8V2h45c24 0 33 2 41 8 8 7 13 18 13 30 0 13-6 23-16 29 15 5 24 17 24 34 0 12-5 23-14 31-11 10-20 13-47 13zm170 0h-28V35h-26V2h106l-17 29c-1 2-4 4-7 4h-19v103c0 5-4 9-9 9zM304 88v26h18c12 0 18-5 18-13 0-9-6-13-18-13h-18zm2-53v22h13c11 0 16-4 16-12 0-7-5-10-16-10h-13zM138 4V2h-2c-1 0-15 0-23 9-7 9-5 23-5 24v2h2c1 0 15 0 23-9 7-9 5-24 5-24z" fill="#80298e" /></svg>
</a>
<div class="c-header__tagline">
Thoughtful, detailed coverage of everything Apple for 30 years<br> and the <a href="https://tcn.tidbits.com/apple-pros/">TidBITS Content Network</a> for Apple professionals
</div>
</div>
<button type="button" class="c-header__toggle" data-toggle="drawer">
<span class="u-hidden-visually">Menu</span>
</button>
<div id="drawer" class="c-header__drawer">
<div class="c-header__search">
<form role="search" method="get" id="searchform" action="https://tidbits.com" class="c-form c-search">
<div class="c-form__field c-form__field--inplace c-search__field js-inplace">
<input type="text" name="s" id="header-search" value="" class="c-form__input c-search__input">
<label for="header-search" class="c-form__label c-search__label">Enter Search</label>
</div>
<button type="submit" class="c-btn-unstyled c-form__button c-search__submit">
<svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 32 32"><title>Search</title><path d="M31 27.2l-7.6-6.4c-.8-.7-1.6-1-2.3-1a12 12 0 1 0-1.3 1.3c0 .7.3 1.5 1 2.3l6.4 7.6c1.1 1.2 3 1.3 4 .2s1-2.9-.2-4zM12 20a8 8 0 1 1 0-16 8 8 0 0 1 0 16z" /></svg>
</button>
</form>
</div>
<div class="c-header__links">
<a href="/login/" class="c-btn-unstyled c-header__link" data-toggle="header-login-form">Log In</a>
<div id="header-login-form" class="c-header__login">
<form class="c-form c-login" method="post" action="https://tidbits.com/wp/wp-login.php">
<input type="hidden" name="action" value="login">
<input type="hidden" name="rememberme" value="forever">
<div class="c-form__field">
<label for="login-username" class="c-form__label">Username or Email Address</label>
<input id="login-username" class="c-form__input" type="text" name="log" autocomplete="username email">
</div>
<div class="c-form__field">
<label for="login-password" class="c-form__label">Password</label>
<input id="login-password" class="c-form__input" type="password" name="pwd" autocomplete="current-password">
</div>
<div class="c-form__buttons">
<button class="c-btn c-btn--primary" type="submit">Log In</button>
<a href="https://tidbits.com/wp/wp-login.php?action=lostpassword" class="c-form__link">Forgot password?</a>
</div>
</form>
</div>
</div>
<nav class="c-nav c-nav--decorated c-header__nav">
<ul class="c-nav__list">
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25068 menu-item-has-children c-nav__item">
<button class="c-nav__link">Weekly Issues</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-46008 c-nav__subitem">
<a href="https://tidbits.com/issues/1517/" class="c-nav__sublink">#1517: Apple on #BlackLivesMatter, export Apple Card statements, Kudoboard for virtual special occasions, videoconferencing tips</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-45829 c-nav__subitem">
<a href="https://tidbits.com/issues/1516/" class="c-nav__sublink">#1516: Security fix for all Apple OSes, macOS 10.15.5 battery health management, Logitech Combo Touch, MFi hearing aid integration</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-45757 c-nav__subitem">
<a href="https://tidbits.com/issues/1515/" class="c-nav__sublink">#1515: Stop force-quitting iOS apps, COVID-19 updates for iOS and iPadOS, AP test nightmares for iPhone/iPad users</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-45626 c-nav__subitem">
<a href="https://tidbits.com/issues/1514/" class="c-nav__sublink">#1514: Beware scheduling via Siri, Apple shipping delays, Eggtronic Power Bar, ExactScan for older ScanSnap scanners, watchOS 6.2.5</a>
</li>
<li class=" menu-item menu-item-type-issue menu-item-object-issue menu-item-45500 c-nav__subitem">
 <a href="https://tidbits.com/issues/1513/" class="c-nav__sublink">#1513: Former Apple engineer on Apple's privacy approach, mirror Apple TV to Mac, WWDC goes virtual, free ACES Conference Prequel, TidBITS 30th podcasts</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25142 c-nav__subitem">
<a href="/issues/" class="c-nav__sublink">All Back Issues</a>
</li>
</ul>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25145 menu-item-has-children c-nav__item">
<button class="c-nav__link">Membership</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21762 c-nav__subitem">
<a href="https://tidbits.com/membership/benefits/" class="c-nav__sublink">Benefits</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-25077 c-nav__subitem">
<a href="https://tidbits.com/membership/levels/" class="c-nav__sublink">Join TidBITS!</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-28753 c-nav__subitem">
<a href="https://tidbits.com/members/" class="c-nav__sublink">TidBITS Members</a>
</li>
</ul>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25094 menu-item-has-children c-nav__item">
<button class="c-nav__link">Get TidBITS</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-25102 c-nav__subitem">
<a href="https://tidbits.com/mailing-lists/" class="c-nav__sublink">Email</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-30771 c-nav__subitem">
<a href="https://apple.news/TjCWZPx-CS2u2x6rWr-PwkQ" class="c-nav__sublink">Apple News</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25100 c-nav__subitem">
<a href="http://www.facebook.com/pages/TidBITS/195314925519" class="c-nav__sublink">Facebook</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-34311 c-nav__subitem">
<a href="https://news.google.com/publications/CAAqBwgKMKD4hgsw-ZaFAw" class="c-nav__sublink">Google News</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-35129 c-nav__subitem">
<a href="https://itunes.apple.com/us/app/tidbits-news/id348629441?mt=8" class="c-nav__sublink">iOS App</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25097 c-nav__subitem">
<a href="https://tidbits.com/feed/" class="c-nav__sublink">RSS</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25099 c-nav__subitem">
<a href="http://www.twitter.com/TidBITS" class="c-nav__sublink">Twitter</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-34369 c-nav__subitem">
<a href="https://www.youtube.com/channel/UC6FJi0g8Dc8Ou3D1YmW8nCA" class="c-nav__sublink">YouTube</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-28764 c-nav__subitem">
<a href="http://slackbits.herokuapp.com/" class="c-nav__sublink">🗣 SlackBITS</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-28765 c-nav__subitem">
<a href="https://talk.tidbits.com/c/tidbits-talk" class="c-nav__sublink">🗣 TidBITS Talk</a>
</li>
</ul>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25146 menu-item-has-children c-nav__item">
<button class="c-nav__link">Categories</button>
<ul class="c-nav__dropdown">
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29406 c-nav__subitem">
<a href="https://tidbits.com/category/aapl/" class="c-nav__sublink">Apple Inc.</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29407 c-nav__subitem">
<a href="https://tidbits.com/category/apple-tv/" class="c-nav__sublink">Apple TV</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21728 c-nav__subitem">
<a href="https://tidbits.com/category/apple-watch/" class="c-nav__sublink">Apple Watch</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29408 c-nav__subitem">
<a href="https://tidbits.com/category/enterprise/" class="c-nav__sublink">Enterprise</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21732 c-nav__subitem">
<a href="https://tidbits.com/category/entertainment/" class="c-nav__sublink">Entertainment</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28402 c-nav__subitem">
<a href="https://tidbits.com/category/automation/" class="c-nav__sublink">Home Automation</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21735 c-nav__subitem">
 <a href="https://tidbits.com/category/inside/" class="c-nav__sublink">Inside TidBITS</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21736 c-nav__subitem">
<a href="https://tidbits.com/category/ios/" class="c-nav__sublink">iPhone, iPad, & iOS</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21737 c-nav__subitem">
<a href="https://tidbits.com/category/fun/" class="c-nav__sublink">Just for Fun</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21739 c-nav__subitem">
<a href="https://tidbits.com/category/mac/" class="c-nav__sublink">Mac & macOS</a>
</li>
<li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-25093 c-nav__subitem">
<a href="/watchlist" class="c-nav__sublink">Mac App Updates</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21740 c-nav__subitem">
<a href="https://tidbits.com/category/creative/" class="c-nav__sublink">Media Creation</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21743 c-nav__subitem">
<a href="https://tidbits.com/category/net/" class="c-nav__sublink">Networking</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21744 c-nav__subitem">
<a href="https://tidbits.com/category/opinion/" class="c-nav__sublink">Opinion</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21748 c-nav__subitem">
<a href="https://tidbits.com/category/problem-solving/" class="c-nav__sublink">Problem Solving</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-21729 c-nav__subitem">
<a href="https://tidbits.com/category/productivity/" class="c-nav__sublink">Productivity</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21747 c-nav__subitem">
<a href="https://tidbits.com/category/security/" class="c-nav__sublink">Security</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21749 c-nav__subitem">
<a href="https://tidbits.com/category/tech/" class="c-nav__sublink">Tech News</a>
</li>
<li class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25214 c-nav__subitem">
<a href="https://tidbits.com/category/tip/" class="c-nav__sublink">Tip</a>
</li>
 </ul>
</li>
</ul>
</nav>
</div>
</header>
<main id="content" class="o-wrapper o-wrapper--narrow" tabindex="-1">
<article id="post-46150" class="c-post">
<header class="c-post__header ">
<a href="https://tidbits.com/author/josh-centers/" class="c-post__author" style="background-color:#2D8299">Josh Centers</a>
<time pubdate="pubdate" datetime="2020-06-12T12:57:47-04:00" class="c-post__date">
12 June 2020
</time>
<a href="#discussion" class="c-post__comments">
4
comments
</a>
<h1 class="c-post__title">BitBar Lets You Put Anything in Your Mac’s Menu Bar</h1>
</header>
<div class="c-post__content">
<div class="c-post__sharing js-sticky">
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><h3 class="sd-title">Share</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-46150" class="share-facebook sd-button no-icon" href="https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-46150" class="share-twitter sd-button no-icon" href="https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button no-icon" href="https://tidbits.com/2020/06/12/bitbar-lets-you-put-anything-in-your-macs-menu-bar/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
</div>
<p>There are all sorts of apps that add various capabilities to your Mac’s menu bar, but I’ve stumbled across one that can add literally <i>anything</i> to the menu bar through a plug-in system. It’s called <a href="https://getbitbar.com/">BitBar</a>, and it’s both free and open source. I’ve tested and confirmed that it works in both macOS 10.14 Mojave and 10.15 Catalina.</p>
<p>When you first launch BitBar, it asks you to choose a directory to store plug-ins. I made a BitBar folder on my iCloud Drive so I can easily sync plug-ins between machines. That works well, and I presume Dropbox or Google Drive would work similarly.</p>
<p>The BitBar Web site contains a rich library of community-created plug-ins. There are plug-ins for displaying weather, stock prices, cryptocurrency prices, email messages, Slack notifications, and pretty much anything you can think of, such as <a href="https://getbitbar.com/plugins/Lifestyle/sureflap.15s.rb">whether your cat is in or out</a>. Installing a plug-in is as easy as clicking the Add to BitBar button on a plug-in’s library page, which installs the plug-in into your specified plug-in folder.</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-6.png"><img class="aligncenter size-large wp-image-46163" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-6-640x166.png" alt="The Add to BitBar button in context." width="640" height="166" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-6-640x166.png 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-6-1536x399.png 1536w, https://tidbits.com/wp/../uploads/2020/06/BitBar-6.png 1999w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p>All BitBar plug-ins are simple text-based shell scripts. Removing one is as simple as moving it out of your plug-in folder, Control-clicking BitBar in the menu bar, and choosing Preferences &gt; Refresh All (I disable plug-ins by putting them in an Archive folder in my plug-in folder). Likewise, you can drag any shell script you want into the plug-in folder and refresh to make it available. You can quickly get to your plug-in folder by Control-clicking BitBar and choosing Preferences &gt; Open Plugin Folder.</p>
<p>That’s the beauty of BitBar: any script that works in Terminal can be a BitBar plug-in. It could be a simple shell script, a Python script, a Ruby script, or even an AppleScript if you put the right hooks in. It also means that you can easily modify all the available plug-ins in <i>any</i> text editor, and you may be able to figure out how to make small changes just by following the script’s example, even if you don’t know the scripting language well. In fact, that’s a common situation.</p>
<h2>Modifying BitBar Plug-ins to Get What You Want</h2>
<p>Imagine that you find a plug-in that does kind of what you want, but not really. The good news is that it’s easy to modify a plug-in.</p>
<p>For instance, I took the <a href="https://getbitbar.com/plugins/Network/got-internet.2s.sh">Got Internet?</a> plug-in, changed its <code>ping_address</code> variable from <code>8.8.8.8</code> (Google DNS) to <code>tidbits.com</code>, and changed the display text so that it shows “TidBITS 👍” when our Web site is reachable and “TidBITS 👎” when it’s not.</p>
<p>Here’s a little hack you might find useful. Install the <a href="https://getbitbar.com/plugins/Web/RSSReader/rss.15m.php">Simple RSS Reader</a> plug-in, open up its file, and change the <code>FEED_URL</code> variable, which is by default <a href="http://feedpress.me/sixcolors?type=xml"><code>http://feedpress.me/sixcolors?type=xml</code></a>, to <code><a href="https://tidbits.com/feed/">https://tidbits.com/feed/</a></code>. You can now access all the latest TidBITS articles from your menu bar!</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-8.jpg"><img class="aligncenter size-large wp-image-46165" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-8-640x482.jpg" alt="BitBar showing the latest TidBITS headlines." width="640" height="482" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-8-640x482.jpg 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-8-1536x1158.jpg 1536w, https://tidbits.com/wp/../uploads/2020/06/BitBar-8.jpg 1778w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p>I also tweaked the <a href="https://getbitbar.com/plugins/Cryptocurrency/CoinbasePrices.sh">Coinbase Prices</a> plug-in. It shows a bunch of different cryptocurrencies by default, but not the one I mostly care about: <a href="https://link.network/">Chainlink</a>. So I simply copied the <code>dash_price</code> line of code, pasted it at the end of the block, renamed it to <code>link_price</code> and changed <code>DASH-USD</code> in the Coinbase URL to <code>LINK-USD</code>. Finally, I added an <code>echo $link_price</code> line at the end. This was just monkey scripting—the script is in Python, which I don’t know well, and my changes worked just fine, aside from not showing a fancy icon on the side of the price.</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-5.jpg"><img class="aligncenter size-large wp-image-46162" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-5-640x147.jpg" alt="Code modified in the Coinbase Prices plug-in to show LINK." width="640" height="147" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-5-640x147.jpg 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-5-1536x353.jpg 1536w, https://tidbits.com/wp/../uploads/2020/06/BitBar-5.jpg 1582w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p>The plug-in that I’ve modified the most heavily—and the one that actually led me to BitBar—is <a href="https://getbitbar.com/plugins/Music/mpd-control.20s.sh">mpd-control</a>. After getting fed up with iTunes/Music messing up my music library, I’ve been experimenting with the command-line-based mpd music daemon, which has a number of front ends. I like the Terminal-based <a href="https://github.com/ncmpcpp/ncmpcpp">ncmpcpp</a>, but it’s awkward having to switch to a Terminal window to pause my music. The mpd-control plug-in, by default, shows the currently playing track and clicking it plays or pauses the music. It was simple enough to change it so that I have a menu of commands that let me play/pause, move to the next or previous track, and open ncmpcpp in a Terminal window.</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-3.jpg"><img class="aligncenter size-large wp-image-46160" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-3-640x283.jpg" alt="The mpd-control plug-in modified to do what I want." width="640" height="283" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-3-640x283.jpg 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-3-1536x680.jpg 1536w, https://tidbits.com/wp/../uploads/2020/06/BitBar-3-1832x814.jpg 1832w, https://tidbits.com/wp/../uploads/2020/06/BitBar-3.jpg 1838w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p>If you’re not as nerdy as I am, there’s also a nice <a href="https://getbitbar.com/plugins/Music/itunes.10s.sh">iTunes Now Playing</a> plug-in to control your music from the menu bar.</p>
<p>For an extreme example, I brought in a menu bar script I use in Linux to <a href="https://github.com/LukeSmithxyz/voidrice/blob/master/.local/bin/statusbar/weather">see the weather forecast</a>. Amazing, it worked pretty much out of the box. I modified it to add an option to open Terminal and <code>curl wttr.io</code>, which brings up a console-based weather forecast.</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-4.jpg"><img class="aligncenter size-large wp-image-46161" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-4-640x329.jpg" alt="wttr.io in a Terminal window." width="640" height="329" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-4-640x329.jpg 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-4-1536x789.jpg 1536w, https://tidbits.com/wp/../uploads/2020/06/BitBar-4.jpg 1999w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<h2>Creating Plug-ins in BitBar</h2>
<p>Let me show you how easy it is to create a BitBar plug-in. If you don’t know any shell scripting, this is a great way to learn, since you can easily integrate your shell scripts with the native macOS interface without much risk. And if you don’t want to learn, you could sweet-talk or pay someone to create the plug-in you need.</p>
<p>You don’t have to start from scratch. The <a href="https://github.com/matryer/bitbar#writing-plugins">BitBar documentation</a> includes several top-to-bottom examples, and the <a href="https://getbitbar.com/plugins/Tutorial">plug-in gallery even has tutorial plug-ins</a> illustrating different concepts that you can modify to your heart’s content. But let me show you how I created a plug-in from scratch to demonstrate how simple it can be.</p>
<p>Open Terminal in <code>/Applications/Utilities</code>. Don’t worry, we’re not doing anything scary. Type <code>date</code> and press Return. You get the current date and time.</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-9.png"><img class="aligncenter size-large wp-image-46166" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-9-640x89.png" alt="Output of &quot;date&quot; in the Terminal." width="640" height="89" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-9-640x89.png 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-9-1122x158.png 1122w, https://tidbits.com/wp/../uploads/2020/06/BitBar-9.png 1140w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p>You can easily put that into BitBar. I opened BBEdit and made this simple script called date.sh. The first line, <code>#!/bin/bash</code>, tells the system that it’s a script. Once you make that text file executable, macOS will recognize it as a program (see below for instructions) and execute any Terminal commands that follow the first line. The next line simply invokes the <code>date</code> command. In other words, typing <code>date</code> in Terminal shows you the current date and time, and if you put that command in a BitBar script, it will do the same thing.</p>
<pre><code>#!/bin/bash
date</code></pre>
<p>Making a script file executable can be a little intimidating if you’re not used to the Terminal, but it’s not hard. You have to do this so it can be run as a program.</p>
<ol>
<li>Open Terminal.</li>
<li>Open the BitBar plug-in folder in Finder.</li>
<li>In the Terminal, type <code>cd </code> (including the trailing space).</li>
<li>Drag the folder icon from the top of the Finder window into Terminal, which inserts the directory path.</li>
<li>Press Return.</li>
<li>Type <code>chmod +x date.sh</code>. This makes the script executable.</li>
</ol>
<p>Refresh BitBar, and you now have a date and time display.</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-2.png"><img class="aligncenter wp-image-46159" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-2.png" alt="A simple &quot;date&quot; plug-in in BitBar." width="319" height="74" /></a></p>
<p>If you type <code>man date</code> in Terminal to see the manual pages for the date command, you’ll see examples of how you can customize the output. Feel free to play around with it.</p>
<p>But what if we want to make it so clicking the date opens the Calendar app? That’s easy to do, but it takes some jiggering. There are special formatting hooks you can add to a script to add BitBar actions, listed on <a href="https://github.com/matryer/bitbar#writing-plugins">BitBar’s GitHub page</a>. But they only work in the context of an <code>echo</code> command, which is a simple Unix command to print text or the value of a variable to the Terminal.</p>
<p>So first, I changed the script to assign the output of the <code>date</code> command to a <code>MYDATE</code> variable, like so: <code>MYDATE=$(date)</code> (note there are no spaces around the equals sign!). Don’t let the symbols intimidate you. You’re simply creating a variable called <code>MYDATE</code>. The dollar sign and parentheses simply tell the system to assign the output of the date command to that variable.</p>
<p>Next, I created a line that tells BitBar to display the date and make it clickable. If I were to write just <code>echo $MYDATE</code>, it would show only the contents of the <code>MYDATE</code> variable—no different than before. But I then added the special BitBar hooks, so it looks like this:</p>
<p><code>echo "$MYDATE | href=file:///Applications/Calendar.app"</code></p>
<p>First, it echoes the <code>MYDATE</code> variable. (Note that in shell scripting, you refer to a variable by putting a dollar sign—$—in front of the variable name.) Inside the quotes, I put not only that <code>MYDATE</code> variable but also the BitBar-specific commands, delimited by the pipe symbol. If you are familiar with HTML, you’ll recognize the <code>href</code> command, which specifies a link. I use that to create a link to the Calendar app.</p>
<p>After a refresh, I could click the date to open the Calendar app. The full script looks like this:</p>
<pre><code>#!/bin/bash

MYDATE=$(date)
echo "$MYDATE | href=file:///Applications/Calendar.app"</code></pre>
<p>But what if you wanted a menu of commands? You can accomplish that by adding <code>echo "---"</code> anywhere in the BitBar plug-in script. However, with the way the plug-in is set up now, I won’t see the menu because it opens Calendar whenever I click it. So I need to change it back to make it not clickable:</p>
<pre><code>#!/bin/bash

date
echo "---"
</code></pre>
<p>But what commands should we put in our menu? Let’s make a clickable link to the Calendar app, like this:</p>
<p><code>echo "Calendar | href=file:///Applications/Calendar.app"</code></p>
<p>All I’m doing here is echoing the word “Calendar” and using the code from the previous example to make it open the Calendar app when clicked.</p>
<p>So our final plug-in script looks like this and shows the date as a menu from which you can open the Calendar app:</p>
<pre><code>#!/bin/bash

date
echo "---"
echo "Calendar | href=file:///Applications/Calendar.app"
</code></pre>
<p>You might notice that the time it reports is slightly off. By default, each BitBar plug-in refreshes once every minute. You can change this by simply adding a timestamp to the filename, like this: <code>date.1s.sh</code>. Change that to <code>date.1h.sh</code> to refresh every hour or <code>date.1d.sh</code> to refresh once per day. Check the <a href="https://github.com/matryer/bitbar#writing-plugins">BitBar documentation</a> for more info.</p>
<p>You can take this basic example and expand it in a few ways:</p>
<ul>
<li>Change the date format</li>
<li>Open other calendar apps like Fantastical or BusyCal</li>
<li>Create a shortcut to the Date &amp; Time preference pane</li>
</ul>
<h2>Making a Bookmarks Plug-in</h2>
<p>I often switch between Web browsers, and I get tired of trying to keep my bookmarks in sync. I could use Alco Blom’s <a href="https://www.url-manager.com/">URL Manager Pro</a>, but in the interests of rolling my own, I’ve been thinking that a good solution would be a simple text file with one URL per line. Text editors like BBEdit usually let you easily follow URLs in text files (in BBEdit, Command-click a URL to open it in your default browser). While playing with BitBar, I thought: “Wait, maybe I could turn a list of links into a plug-in.” It turned out to be pretty easy, though I’m still working on perfecting it.</p>
<p>My first plug-in along these lines was extremely basic. I created a list of URLs and saved it in <code>~/Documents/urls.txt</code>. (If you want to follow along, you can name it whatever you want and store it wherever you want.)</p>
<p>I then structured the script like so:</p>
<pre><code>#!/bin/bash # Tell the system this is a script

LINKFILE=~/Documents/urls.txt
# Create a variable called LINKFILE that points to my URL list,
# which is cleaner than referring to the list directly in the code.

echo "URLs"
echo "---"
</code></pre>
<p>These two lines tell BitBar to make “URLs” the display name and echo <code>---</code> to indicate a submenu.</p>
<p>Here’s where things get interesting. We’re going to bring in our URL list and echo each line along with the command that tells BitBar it’s a link.</p>
<pre><code>while read line; do
    echo "$line|href=$line"
done &lt;$LINKFILE
</code></pre>
<p>The key part is at the end, <code>&lt;$LINKFILE</code>, which tells the shell to import every line of that file into the <code>while</code> loop. <code>while read line</code> translates to “While this file has a line I have not processed, read the line in and store it in variable line.” And <code>do</code> just means do. While there are lines to process, it will echo that line, <code>$line</code>, along with the pipe character and <code>href=</code>, which tells BitBar that the following text is a link. The second <code>$line</code> simply tells BitBar to link the title <code>$line</code> to the URL <code>$line</code>. In this case, the link title and link URL are identical.</p>
<p>In practice, it looks like this:</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-1.jpg"><img class="aligncenter wp-image-46158" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-1-640x335.jpg" alt="A simple bookmarks plug-in with raw URLs." width="475" height="248" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-1-640x335.jpg 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-1.jpg 696w" sizes="(max-width: 475px) 100vw, 475px" /></a></p>
<p>That works, but I’d rather have descriptive names instead of raw URLs. Also, I have a lot of bookmarks and only so much screen real estate. So I tried my hand at creating a Markdown-based bookmark file that would contain descriptive names and a menu hierarchy. Such text processing necessitated using regular expressions, and the simplest way to do that in a shell script is the <code>sed</code> command, with which I’m not very familiar. So I Googled enough <code>sed</code> commands to make it sort of work:</p>
<pre><code>#!/bin/bash

LINKFILE=~/Documents/SyncThing/links.md

echo "Bookmarks"
echo "---"

while read line; do
    [ -z "$line" ] &amp;&amp; continue
    LINKNAME=`echo $line | sed 's/^.*\[//;s/\].*$//'`
    LINK=`echo $line | sed 's/^.*(//;s/).*$//'`
    echo "$LINKNAME|href=$LINK"
done &lt;$LINKFILE
</code></pre>
<p>The above code isn’t that different from the first bookmark script. It cycles through a list of links, only in Markdown this time, and in each line it uses <code>sed</code> to extract either the title or the URL and add it to a variable. It then echoes the <code>LINKNAME</code> variable and tells BitBar to link it to the URL stored in <code>LINKURL</code>. The <code>[ -z "$line" ] &amp;&amp; continue</code> line at the top of the <code>while</code> loop tells the shell to skip blank lines.</p>
<p>Note the backticks (`) around the commands assigned to <code>LINKNAME</code> and <code>LINK</code>. That tells macOS to assign the results of the commands to the variable instead of just the text.</p>
<p>I have one problem with this setup. The way BitBar does sub-menus is weird. In Markdown, headings work like this:</p>
<pre><code>#Bookmarks
[TidBITS](https://tidbits.com/)
[TidBITS Talk](https://talk.tidbits.com/)
[The Prepared](https://theprepared.com/)

##News
[Slashdot](https://slashdot.org/)
</code></pre>
<p>A single <code>#</code> indicates a top-level header, <code>##</code> is a subhead, and so on. However, to get it to work with BitBar, I have to format my Markdown URL list like this:</p>
<pre><code>[TidBITS](https://tidbits.com/)
[TidBITS Talk](https://talk.tidbits.com/)
[The Prepared](https://theprepared.com/)

News
[--Slashdot](https://slashdot.org/)
</code></pre>
<p>So the subfolder name is “News,” and to indicate that an item goes into that subfolder, I have to put two dashes <code>--</code> in front of the line. I’m sure it’s possible to create a script to count the number of lines under a Markdown header, strip away the <code>#</code> characters, and insert <code>--</code> in front of each line under the header, but I don’t know <code>sed</code> and <code>awk</code> that well. (If you do, let me know, and you’ll earn my eternal regular expression appreciation.)</p>
<p>However, the result in BitBar is nice and tidy, and choosing one of these bookmarks from the menu opens it in my default Web browser. When I switch browsers, all I have to do is change which one is the default to make my bookmarks work with the new one instead.</p>
<p><a href="https://tidbits.com/wp/../uploads/2020/06/BitBar-7.jpg"><img class="aligncenter wp-image-46164" src="https://tidbits.com/wp/../uploads/2020/06/BitBar-7-640x317.jpg" alt="The Markdown bookmark plug-in in action." width="476" height="236" srcset="https://tidbits.com/wp/../uploads/2020/06/BitBar-7-640x317.jpg 640w, https://tidbits.com/wp/../uploads/2020/06/BitBar-7.jpg 734w" sizes="(max-width: 476px) 100vw, 476px" /></a></p>
<h2>BitBar Can Be Anything You Want</h2>
<p>I hope I’ve given you a good idea of some of the things you can do with BitBar, even if you’re not super comfortable with the Terminal or scripting. If you’ve ever thought, “I wish I could put that in my menu bar,” there is probably a way to do it with BitBar. Your only limits are your imagination and what you or someone you know can do in a shell script.</p>
<p>If you want to download the BitBar plug-ins I’m using, creating, and editing, you can find them on my <a href="https://github.com/jcenters/BitBar-plugins">GitHub page</a>.</p>
</div>
</article>
<div class="c-banner c-banner--success c-cta">
<div id="sendgrid_mc_email_subscribe">
<h2 class="h4">Subscribe today so you don’t miss any TidBITS articles!</h2>
<p>Every week you’ll get tech tips, in-depth reviews, and insightful news analysis for discerning Apple users. For 29 years, we’ve published professional, member-supported tech journalism that makes you smarter. </p>
<form action="/wp/wp-login.php?action=register" method="post" class="c-form c-form--inline">
<div class="c-form__field c-form__field--inplace js-inplace">
<input type="email" name="user_email" id="cta-signup-email" class="c-form__input">
<label for="cta-signup-email" class="c-form__label">Email Address</label>
</div>
<input type="hidden" name="user_issue_subscription" value="1">
<button type="submit" class="c-btn c-btn--primary c-btn--small">Subscribe</button>
</form>
<p>Registration confirmation will be emailed to you.</p>
</div>
</div>
<aside class="o-wrapper__breakout c-ad c-ad--image" data-ad-campaign="Take Control Books - tco-ios13-ipados13">
<div class="c-ad__inner">
<a href="https://www.takecontrolbooks.com/ios-13-ipados-13/?pt=TBAD"><picture><source srcset="https://tidbits.com/wp/../uploads/2018/02/TCo-iOS13-iPadOS13-ad-640x200_v1.png" media="(max-width: 600px)" type="image/png"><img src="https://tidbits.com/wp/../uploads/2018/02/TCo-iOS13-iPadOS13-ad-1456x180_v1.png" srcset="https://tidbits.com/wp/../uploads/2018/02/TCo-iOS13-iPadOS13-ad-1456x180_v1.png 1456w, https://tidbits.com/wp/../uploads/2018/02/TCo-iOS13-iPadOS13-ad-1456x180_v1-640x79.png 640w" alt="Take Control of iOS 13 and iPadOS 13, by Josh Centers"></picture></a>
</div>
</aside>
<aside id="related-articles" class="o-wrapper__breakout">
<div class="c-posts-callout">
<div class="c-post__terms">
<a href="https://tidbits.com/tag/applescript/" class="c-badge">AppleScript</a>
<a href="https://tidbits.com/category/productivity/" class="c-badge">Productivity</a>
<a href="https://tidbits.com/tag/scripting/" class="c-badge">scripting</a>
<a href="https://tidbits.com/tag/terminal/" class="c-badge">Terminal</a>
</div>
</div>
</aside>
<section id="discussion" class="c-comments">
<h2 class="c-comments__title">
<span class="u-size-small">Comments About</span>
BitBar Lets You Put Anything in Your Mac’s Menu Bar
</h2>
<div id="comments" class="comments-area discourse-comments-area">
<div class="comments-title-wrap">
<h2 class="comments-title discourse-comments-title">Notable Replies</h2>
</div>
<ol class="comment-list"> <li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/tjluoma/64/2656_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/t/bitbar-lets-you-put-anything-in-your-mac-s-menu-bar/12668" rel="external" class="url">tjluoma</a></b>
</div>
<div class="comment-metadata">
<time datetime="12 June 2020">12 June 2020</time>
</div>
</footer>
<div class="comment-content"><p>BitBar is nice, but as far as I can tell, it’s no longer being developed.</p>
<p>A newer alternative is <a href="http://richsomerfield.com/apps/textbar/" rel="nofollow noopener">TextBar</a> which does similar things, and the developer has been very open to ideas and suggestions.</p>
<p>It is definitely nice to be able to output shell commands to your menu bar. I have one which shows me a better indication of Time Machine’s status and progress, my git repos, and various bits of system information including the SSID that I am connected to and whether or not my VPN is active.</p>
</div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/jcenters/64/3048_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/t/bitbar-lets-you-put-anything-in-your-mac-s-menu-bar/12668" rel="external" class="url">Josh Centers</a></b>
</div>
<div class="comment-metadata">
<time datetime="12 June 2020">12 June 2020</time>
</div>
</footer>
<div class="comment-content"><p>I looked at BitBar’s GitHub. The last commit was a year ago and the developer is still responding to concerns, so I don’t think it’s dead, just not frequently updated. I’ll check out TextBar, but I like the fact that BitBar is open source.</p></div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/letter_avatar_proxy/v4/letter/t/5fc32e/64.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/t/bitbar-lets-you-put-anything-in-your-mac-s-menu-bar/12668" rel="external" class="url">Tonycr46</a></b>
</div>
<div class="comment-metadata">
<time datetime="12 June 2020">12 June 2020</time>
</div>
</footer>
<div class="comment-content"><p>It sounds like an interesting idea, but I am leery of having an app that adds <em>yet more</em> stuff to my menubar. I use Bartender, but I still have a lot of items up there. What would be useful is a menubar dropdown for apps that are in the menu bar. I could group my items into discreet groups and call on them as I need them. I have something in the recesses of my mind that is telling me Butler can do that. I’ll have to check.</p></div>
</article>
</li>
<li class="comment even thread-even depth-1">
<article class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/tommy/64/63_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
<b class="fn"><a href="https://talk.tidbits.com/t/bitbar-lets-you-put-anything-in-your-mac-s-menu-bar/12668" rel="external" class="url">Tommy Weir</a></b>
</div>
<div class="comment-metadata">
<time datetime="13 June 2020">13 June 2020</time>
</div>
</footer>
<div class="comment-content"><p>Both of these sound like fun. Will check them out.</p></div>
</article>
</li>
</ol>
<div class="respond comment-respond">
<h3 id="reply-title" class="comment-reply-title">
Join the discussion in <a class="wpdc-discourse-topic-link" target="_blank" href="https://talk.tidbits.com/t/bitbar-lets-you-put-anything-in-your-mac-s-menu-bar/12668">the TidBITS Discourse forum</a>
</h3>
<p class="more-replies"></p>
<div class="comment-reply-title">
<h4 class="discourse-participants">Participants</h4>
<p> <img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/jcenters/64/3048_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/tommy/64/63_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/letter_avatar_proxy/v4/letter/t/5fc32e/64.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
<img alt="" src="https://talk.tidbits.com/user_avatar/talk.tidbits.com/tjluoma/64/2656_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
</p>
</div>
</div>
</div>
<ul class="comment-list">
</ul>
</section>
</main>
<footer class="o-wrapper c-footer">
<div class="c-footer__inner">
<p class="c-footer__copyright o-type-small">
<strong>TidBITS</strong> is copyright © 2020 TidBITS Publishing Inc.
Reuse governed by Creative Commons License.
</p>
<nav class="c-nav c-footer__nav">
<ul class="c-nav__list">
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21698 c-nav__item">
<a href="https://tidbits.com/about/" class="c-nav__link">About</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21697 c-nav__item">
<a href="https://tidbits.com/about/advertise/" class="c-nav__link">Advertise</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-28746 c-nav__item">
<a href="https://tidbits.com/about/code-of-conduct/" class="c-nav__link">Code of Conduct</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21696 c-nav__item">
<a href="https://tidbits.com/about/contact/" class="c-nav__link">Contact</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-21695 c-nav__item">
<a href="https://tidbits.com/about/copyright/" class="c-nav__link">Copyright</a>
</li>
<li class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-21694 c-nav__item">
<a href="https://tidbits.com/about/privacy/" class="c-nav__link">Privacy Notice</a>
</li>
</ul>
</nav>
<a href="https://madebyneversink.com" class="c-footer__credit">
Design by <svg xmlns="http://www.w3.org/2000/svg" width="102" height="19" viewBox="0 0 518 94"><title>Neversink</title><g fill="#a7630b"><path d="M114.7 45.6c1 2.2 1.6 4.2 2.6 6L119 44c8.5-34 26.6-42.3 39.2-42.3 10.6 0 16 5 16 10 0 3.6-2.5 7-6.5 7-7.7 0-5.7-10.3-14-10.3-7.6 0-19.3 6.2-26.6 29-2 7-4.3 15.6-6.3 23.8 7.7 17.5 14.8 25.7 22 25.7 7.6 0 6.7-11 14.7-11 3.3 0 5.7 2 5.7 5.8 0 6-7.2 11-19 11-16.7 0-30.8-12.4-41.7-43L90 16.7l-4 16.7c-11.3 46.5-36.5 57-57.2 57C11.4 90 1.2 79.2 1.2 66c0-14.7 13.3-23.8 26.7-23.8 12 0 21 6.8 21 14.8 0 3.8-2.6 7-6.7 7-4.8 0-6.2-4-7-8.3-.8-4-2-8.2-9.2-8.2A19 19 0 0 0 7 66.1C7 77 15.4 85 29 85c19 0 41-10 51.3-51.6l4.2-17c1-4.4-.7-5-3.8-6.2-2.5-1-7.8-1.8-14.2-1.8-15 0-21.6 7-21.6 14.8 0 4.4 2.4 8 7 8 7.2 0 5.6-11 13.8-11 3.7 0 5.8 2.8 5.8 6 0 6.5-8 11.6-16.3 11.6-10.6 0-16-6-16-14 0-11 9.4-20.4 28-20.4 11.8 0 17 2.6 27 2.6h5.8l14.4 39.6z" /><path d="M148 45.6c-.6 3-1 6.4-1 9 0 7 3.5 11.6 10.8 11.6 5.7 0 11.3-3.8 15.7-10.4l3.8 2.6c-5.5 8.4-12 13-21 13-12.8 0-20.5-8.2-20.5-18.5 0-16 11.5-26 25-26 11.5 0 19.2 6.4 17.2 18.8h-30v-.2zm1.6-4.7h18.6c1.3-6.5-1.8-9.6-7-9.6-5.8 0-9.4 4.2-11.6 9.5zM193 70l-4.7-31.5c-.7-4.8-1-6.8-4.8-7.3l.7-3H207l-.8 3c-5.7.4-7.5 2-7 6.4l2.8 20 12.8-19.7c3-5 2.4-6.3-2.4-7l.7-2.8h16.5l-.7 3c-3.5.3-5.5 2-8.6 7.2L199.8 70h-7zm45-24.5c-.7 3-1 6.4-1 9 0 7 3.4 11.6 10.7 11.6 5.6 0 11.2-3.8 15.6-10.4l3.7 2.6c-5.5 8.4-12 13-21 13-12.8 0-20.5-8.2-20.5-18.5 0-16 11.5-26 25-26 11.5 0 19.2 6.4 17.2 18.8h-29.8v-.2zm1.5-4.7h18.6c1.3-6.5-1.8-9.6-7-9.6-6 0-9.6 4.2-11.6 9.5zm28.8 29l.7-3.2c4.8-.4 5.8-1.5 6.8-4.4l5.5-22.7c.5-2 0-2.7-1.8-2.7h-3l.6-2.7 14.6-7.5h4l-1.6 6.2c6.8-10.6 17.4-20.6 25.8-20.6 4 0 7 2.2 7 5.7 0 3.4-2.6 5.8-5.7 5.8-3.7 0-3.7-2.2-6.8-2.2-5.8 0-16.4 10.2-23.4 23.6l-4 17.5c-.6 3 0 3.8 4.5 4.4l-.7 3h-22.3z" /><path d="M292.3 75.6c0-7.5 6.6-12 13.7-12 7.7 0 12.6 5.8 18 11.2.6-1.6 1-3.5 1-5 0-15.2-22-14.5-22-29 0-8.8 7.6-14.3 17.6-14.3 6 0 10 1.6 12.6 3.7l1.3-2.2h2.7l1 14.3-2.8.7c-2.7-8.2-7.7-12-13.7-12-4.8 0-8.6 2.5-8.6 6.5 0 9.7 21.8 10 21.8 28.5 0 4.8-2 10-5.8 14 4.2 3.8 9 6.7 16 6.7 7.4 0 5.4-9.7 12.3-9.7 2.4 0 4.4 1.6 4.4 4.2 0 5.7-7 10.2-17 10.2-8.2 0-14.2-3.8-19.2-8.4-4 3-9 5-15.5 5-9.7 0-17.7-4.2-17.7-12.4zm29 3.3c-5-5.4-9.4-10.5-15.4-10.5-5 0-8.3 2.7-8.3 7 0 5.6 5.8 8.3 12.2 8.3a16 16 0 0 0 11.4-5z" /><path d="M338.3 70l.7-3.2c4.7-.4 5.8-1.5 6.8-4.4l5.5-22.7c.6-2 0-2.7-1.8-2.7h-3l.6-2.7 14.7-7.5h4L357 62.4c-.8 3 0 3.8 4.3 4.4l-.7 3h-22.3zM364 6.2c4 0 6.5 3 6.5 6.4 0 3.3-2.7 6.6-7 6.6-4 0-6.5-3-6.5-6.2 0-3.4 2.5-6.7 7-6.7zM398 70l7.2-30c1.3-5-1-7-4.6-7a22 22 0 0 0-10.8 3.3l-6.3 26c-.7 3 0 4 4.4 4.5l-.8 3H365l.6-3c4.8-.4 5.8-1.5 6.8-4.4l5.5-22.7c.4-2 0-2.7-2-2.7h-3l.7-2.7 14.6-7.5h4l-1 4.4a32 32 0 0 1 15-4.4c6 0 13.2 2.2 10.5 13.3l-5.5 22.6c-.7 3 0 3.8 4.4 4.4l-.7 3h-17zm20.8 0l.7-3.2c4.8-.4 5.8-1.5 6.8-4.4l11-45c.5-2 0-2.7-1.8-2.7h-3l.6-2.7 14.7-7.3h4L442 44.2l9.5-7.3c27.2-21.3 39-28.6 52.4-28.6 5.7 0 13 3 13 8.6 0 3-2 5.5-5.4 5.5-6 0-4-7-13-7-8.4 0-18.5 6.5-37.5 20.7l-6.7 5L464.5 62c2 4.2 3.8 5 6.4 5.5l-.8 3H456l-11-21.8-5 3.8-2.6 10.8c-.7 3 0 4 4.4 4.5l-.7 3h-22.4V70h.2z" /></g></svg>
</a>
</div>
</footer>
<div id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="hide-on-button" data-hide-timeout="30" data-consent-expiration="180" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and Accept" class="accept" />
</form>
Cookies &amp; Privacy: We wish we were talking about chocolate-chip cookies here, but our Web site—like nearly all others—relies on a few minor digital cookies. Various laws around the world require us to tell you that fact, so consider yourself informed, if not nourished. By continuing to use this site, you agree to our use of these cookies.
<a href="https://tidbits.com/about/privacy/">
Cookie and Privacy Notice	</a>
</div>
</div>
<script src="https://cdn.polyfill.io/v2/polyfill.min.js?features=Array.from,Array.forEach,Object.assign"></script>
<script src="https://tidbits.com/app/themes/tidbits/scripts/main.js?id=4d111fbcb932b4f4f4ae" defer="defer"></script>
<script type='text/javascript'>
var renderInvisibleReCaptcha = function() {

    for (var i = 0; i < document.forms.length; ++i) {
        var form = document.forms[i];
        var holder = form.querySelector('.inv-recaptcha-holder');

        if (null === holder) continue;
		holder.innerHTML = '';

         (function(frm){
			var cf7SubmitElm = frm.querySelector('.wpcf7-submit');
            var holderId = grecaptcha.render(holder,{
                'sitekey': '6LcQSFMUAAAAAO-4itAckqGlBhzt1MSzkfsGRagG', 'size': 'invisible', 'badge' : 'bottomright',
                'callback' : function (recaptchaToken) {
					if((null !== cf7SubmitElm) && (typeof jQuery != 'undefined')){jQuery(frm).submit();grecaptcha.reset(holderId);return;}
					 HTMLFormElement.prototype.submit.call(frm);
                },
                'expired-callback' : function(){grecaptcha.reset(holderId);}
            });

			if(null !== cf7SubmitElm && (typeof jQuery != 'undefined') ){
				jQuery(cf7SubmitElm).off('click').on('click', function(clickEvt){
					clickEvt.preventDefault();
					grecaptcha.execute(holderId);
				});
			}
			else
			{
				frm.onsubmit = function (evt){evt.preventDefault();grecaptcha.execute(holderId);};
			}


        })(form);
    }
};
</script>
<script type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?onload=renderInvisibleReCaptcha&#038;render=explicit'></script>
<script type='text/javascript' src='https://tidbits.com/app/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js?ver=20180522'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202024.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'144794781',post:'46150',tz:'-4',srv:'tidbits.com'} ]);
	_stq.push([ 'clickTrackerInit', '144794781', '46150' ]);
</script>
</body>
</html>


