Skip to content
Thoughtful, detailed coverage of everything Apple for 28 years
and the TidBITS Content Network for Apple professionals

Japanese or Chinese Language Kit users

Japanese or Chinese Language Kit users must wait to upgrade to System 7.5 until updates for each language kit are released around the end of this year. The System 7.5 Read Me file suggests upgrading to version 1.1.1 of the language kits, which do not yet exist. The QuickDraw GX URGENT Read Me file says the GX software requires WorldScript II version 7.2 or later, but in fact the language kit update is required as well. [MHA]

Subscribe today so you don’t miss any TidBITS articles!

Every week you’ll get tech tips, in-depth reviews, and insightful news analysis for discerning Apple users. For 28 years, we’ve published professional, member-supported tech journalism that makes you smarter.

Registration confirmation will be emailed to you.